couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From George Burt <>
Subject Amazon AMI guidance
Date Tue, 01 Feb 2011 17:11:03 GMT
It is my intention to get CouchDB working in the Amazon EC2 environment.

I have had a few problems.  I first tried the Amazon Linux, which is CentOS
5.5.  I got to a point where I didn't know where to go and google did not

So I decided to try unbuntu.  Same result.  Then I went down the list on

I did not try Red Hat Enterprise, because it requires a subscription.

Debian (Lenny) - Failed
Ubuntu (lucid Lync) - Failed
Ubuntu (Karmic Koala), Fedora 13, OpenSUSE 11.3 (two versions) - All Failed.

In all I have tried 15 AMI's.  Most of them failed fairly early in the
process (by fail, I mean I got to a point where an error occurred and I
could not find out what to do about it from google searches.)  Some problems
had to do with the fact that some of the distributions don't want you to log
in as root, so you have to use sudo and su -.  Sometimes I simply could not
find the root password (for su-), clearly this has nothing to do with
couch.  But several times, rake would refuse to run at all.  More often,
rake would run ending with "rake aborted" (one time after an hour of
building.)  The Fedora actually seemed to get all the way through, but alas,
the bin directory was empty.

There no 1.x AMI's out there for couch (that I could find).

Obviously, I am not Linux savvy, but I am also not quite a newbie.

Any direction would be appreciated.


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message