couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pasi Eronen>
Subject CouchDB 1.0.2 errors under load
Date Fri, 25 Feb 2011 09:18:47 GMT

I had a big batch job (inserting 10M+ documents and generating views for them)
that ran just fine for about 6 hours, but then I got this error:

[Thu, 24 Feb 2011 19:42:57 GMT] [error] [<0.276.0>] ** Generic server
<0.276.0> terminating
** Last message in was delayed_commit
** When Server state == {db,<0.275.0>,<0.276.0>,nil,<<"1298547642391489">>,
** Reason for termination ==
** {{badmatch,{error,emfile}},

(+lot of other messages with the same timestamp -- can send if they're useful)

Exactly at this time, the client got HTTP 500 status code; the request
was a bulk get (POST /foo_replication_tmp/_all_docs?include_docs=true).

Just before this request, the client had made a PUT (updating an existing
document) that got 200 status code, but apparently was not successfully
committed to the disk (I'm using "delayed_commits=true" - for my app,
this is just fine). The client had received the new _rev value, but when
it tried updating the same document a minute later, there was a conflict
(and it's not possible that somebody else updated this same document).

About four hours later, there was a different error ("accept_failed"
sounds like some temporary problem with sockets?):

[Thu, 24 Feb 2011 23:55:42 GMT] [error] [<0.20693.4>] {error_report,<0.31.0>,
                "Accept failed error","{error,emfile}"]}}

[Thu, 24 Feb 2011 23:55:42 GMT] [error] [<0.20693.4>] {error_report,<0.31.0>,

(+lots of other messages within the next couple of minutes)

The same error occured once more, about four hours later.

I'm quite new to CouchDB, so I'd appreciate any help in interpreting
what these error messages mean. (BTW, are these something I should
report as bugs in JIRA? I can do that, but I'd like to at least understand
which parts of the error messages are actually relevant here :-)

I'm running CouchDB 1.0.2 with Erlang R14B on 64-bit RHEL 5.6.

Best regards,

View raw message