Sorry for that...
I did some more digging. The original error I was getting was the result of an typo within the couchapp code, so I was able to resolve that. Unfortunately, that did not resolve my ajax issue. I have attached a snapshot of the output from firebug showing the responses I was getting. Something else I tried was to use the jquery lib, but had similar issues with it.

Here is the code snippet for each of them:
     <script type="text/javascript" charset="utf-8">
        db = $.couch.db("sessions");
        $.log('info :' +;

    <script type="text/javascript" charset="utf-8">   
        $.getJSON('_list/sort/srcAddr?group=true', function(data) {
            $.log('list: ' + data)});

Just to summarize these in reference to the snapshot, the first 'GET' response is responding to the As you can see the correct response is there, but when I try to log it, I get 'undefined'. Similar to that, the second 'GET' is in response to the .getJSON, where I get the correct response, but when I try to log it, I am not getting what I would expect to see. Not sure where the third 'GET' is coming from, but the fourth one is coming from Evently.

Hope this helps

Thanks in advance for you help

Stefan Matheis
January 19, 2011 12:23 AM

Hey Chris,

"... but get an error. ..." is a bit of no-information :/ which error did
you get? with firefox/firebug or chrome, check your console to access the
accessing your couchdb with the same url works?


Chris Johnson
January 18, 2011 6:33 PM

I am new to couchdb and have been successfully using it with the python libs. I am trying to move to JS, which I am new to as well, and having some challenges. I know this is a simple question, so please bare with me. I am trying to make a simple ajax call to pull data from a view but get an error. I have tried with both the full URL and just he view information with no luck. What am I missing?

<script type="text/javascript" charset="utf-8">
         $.getJSON("_view/status", function(data) {
            alert("JSON Data: " + data);