couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Volker Mische <volker.mis...@gmail.com>
Subject Re: GeoCouch runtime error druing bbox request
Date Tue, 18 Jan 2011 16:03:44 GMT
Hi Bernhard,

I've xulrunner-1.9.2 and xulrunner-1.9.2-dev installed. Though my js lib 
file is called libmozjs.so. The current location of your libjs.so sounds 
like it comes from your previous attempts installing SpiderMonkey from 
source.

Cheers,
   Volker

On 18.01.2011 15:53, e0075088@student.tuwien.ac.at wrote:
>
> Hi Volker,
>
> thanks for the quick response. When I first tried out your solution
> you've provided me, it didn't work for me for some reason. I tried
> different things like creating an xulrunner.conf file as described here:
> http://wiki.apache.org/couchdb/Installing_on_Ubuntu. But it seems that
> my xulrunner-1.9.2.13 don't even contain the requested libjs.so file.
>
> So I've performed a quick search for all libjs.so files on my system and
> tried there paths. In the end it worked with the following command:
> LD_LIBRARY_PATH=/usr/local/lib64 ./utils/run
>
> With this path your solution worked for me, but I've to admit I hardly
> know what I'm doing and why this seems to works now. Maybe this problem
> occur because I previously installed Spider Monkey from source beside
> xulrunner when messing around with the GeoCouch installation but in fact
> I've no idea. Maybe you can enlighten me, as I don't see through all
> these dependencies and libraries. (BTW my GeoCouch is running on Ubuntu
> 10.10).
>
> Regards
> Bernhard
>
> Am Dienstag, den 18.01.2011, 10:15 +0100 schrieb Volker Mische:
>> Hi Bernhard,
>>
>> the problem looks like your JavaScript libs (SpiderMonkey) can't be
>> found. Try to run ./utils/run as
>> LD_LIBRARY_PATH=/usr/lib/xulrunner-1.9.2.13 ./utils/run
>>
>> Cheers,
>> Volker
>>
>> On 01/17/2011 09:49 PM, e0075088@student.tuwien.ac.at wrote:
>> > Hello,
>> > my name is Bernhard, I'm new to this community and I hope this is the
>> > right place for my question.
>> > > I'm currently writing my bachelor thesis where I have to implement
>> some
>> > kind of geo-wiki (I study geomatics). To accomplish this I would
>> like to
>> > use GeoCouch. I've installed the version I've found on
>> > https://github.com/vmx/couchdb/ (installation notes below) but every
>> > time I try to execute the GeoCouch "hello world" equivalent
>> described at
>> > github ("Using GeoCouch"), I get the following error when I perform the
>> > bounding box request (curl -X GET
>> >
>> 'http://localhost:5984/places/_design/main/_spatial/points?bbox=0,0,180,90'):
>>
>> > > > /opt/couchdb/src/couchdb/priv/couchjs: error while loading shared
>> > libraries: libjs.so: cannot open shared object file: No such file or
>> > directory
>> > [error] [<0.380.0>] OS Process Error <0.1395.0> ::
>> > {os_process_error,{exit_status,127}}
>> > > I've tried to reinstall GeoCouch with different configurations and at
>> > different places (currently at /opt/couchdb). I alos tried to simply
>> > copy the libjs.so file to the requested directory, but nothing worked
>> > for me. Now I'm stuck. But I'm sure there must be a simple solution but
>> > I simply don't get it...
>> > > I would be pleased if someone could help me
>> > Bernhard
>> > > Installation log:
>> > $ sudo su
>> > $ apt-get install build-dep couchdb
>> > $ apt-get install xulrunner-dev libicu-dev libcurl4-gnutls-dev libtool
>> > $ apt-get install automake
>> > $ cd /opt/
>> > $ git clone git://github.com/vmx/couchdb.git
>> > $ cd couchdb
>> > $ ./bootstrap
>> > $ ./configure --with-js-lib=/usr/lib/xulrunner-devel-1.9.2.13/lib
>> > --with-js-include=/usr/lib/xulrunner-devel-1.9.2.13/include
>> > $ make dev
>> > $ ./utils/run
>>


Mime
View raw message