couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject GeoCouch runtime error druing bbox request
Date Mon, 17 Jan 2011 20:49:18 GMT
my name is Bernhard, I'm new to this community and I hope this is the  
right place for my question.

I'm currently writing my bachelor thesis where I have to implement  
some kind of geo-wiki (I study geomatics). To accomplish this I would  
like to use GeoCouch. I've installed the version I've found on (installation notes below) but every  
time I try to execute the GeoCouch "hello world" equivalent described  
at github ("Using GeoCouch"), I get the following error when I perform  
the bounding box request (curl -X GET  

/opt/couchdb/src/couchdb/priv/couchjs: error while loading shared  
libraries: cannot open shared object file: No such file or  
[error] [<0.380.0>] OS Process Error <0.1395.0> ::  

I've tried to reinstall GeoCouch with different configurations and at  
different places (currently at /opt/couchdb). I alos tried to simply  
copy the file to the requested directory, but nothing worked  
for me. Now I'm stuck. But I'm sure there must be a simple solution  
but I simply don't get it...

I would be pleased if someone could help me

Installation log:
$ sudo su
$ apt-get install build-dep couchdb
$ apt-get install xulrunner-dev libicu-dev libcurl4-gnutls-dev libtool
$ apt-get install automake
$ cd /opt/
$ git clone git://
$ cd couchdb
$ ./bootstrap
$ ./configure --with-js-lib=/usr/lib/xulrunner-devel-  
$ make dev
$ ./utils/run

View raw message