couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriel Farrell...@grrawr.com>
Subject Re: Odd problem getting starting on Debian
Date Fri, 05 Nov 2010 19:14:46 GMT
How did you install CouchDB? Are you able to create other databases?

On Fri, Nov 5, 2010 at 8:06 AM, David Goodenough
<david.goodenough@linkchoose.co.uk> wrote:
> I have a Debian (unstable) machine, and I installed CouchDB on it.  I can
> start up Futon, and the Futon UI starts.  If I then go to the test suite
> and run all tests, they all come back complaining that the database does
> not exist.   The first few lines of the log are:-
>
> [Fri, 05 Nov 2010 11:37:39 GMT] [info] [<0.31.0>] Apache CouchDB has
> started on http://127.0.0.1:5984/
>
> [Fri, 05 Nov 2010 11:37:52 GMT] [debug] [<0.97.0>] 'GET' / {1,1}
> Headers: [{'Accept',"text/html, image/jpeg;q=0.9, image/png;q=0.9,
> text/*;q=0.9, image/*;q=0.9, */*;q=0.8"},
>          {'Accept-Charset',"utf-8, utf-8;q=0.5, *;q=0.5"},
>          {'Accept-Encoding',"x-gzip, x-deflate, gzip, deflate"},
>          {'Accept-Language',"en-US, en"},
>          {'Connection',"Keep-Alive"},
>          {'Host',"localhost:5984"},
>          {'Referer',"http://localhost:5984/_utils/couch_tests.html?script/couch_tests.js"},
>          {'User-Agent',"Mozilla/5.0 (compatible; Konqueror/4.4; Linux)
> KHTML/4.4.5 (like Gecko)"}]
>
> [Fri, 05 Nov 2010 11:37:52 GMT] [debug] [<0.97.0>] OAuth Params: []
>
> [Fri, 05 Nov 2010 11:37:52 GMT] [info] [<0.97.0>] 127.0.0.1 - - 'GET' / 200
>
> [Fri, 05 Nov 2010 11:37:52 GMT] [debug] [<0.111.0>] 'GET' /test_suite_db/
> {1,1}
> Headers: [{'Accept',"text/html, image/jpeg;q=0.9, image/png;q=0.9,
> text/*;q=0.9, image/*;q=0.9, */*;q=0.8"},
>          {'Accept-Charset',"utf-8, utf-8;q=0.5, *;q=0.5"},
>          {'Accept-Encoding',"x-gzip, x-deflate, gzip, deflate"},
>          {'Accept-Language',"en-US, en"},
>          {'Connection',"Keep-Alive"},
>          {'Host',"localhost:5984"},
>          {'Referer',"http://localhost:5984/_utils/couch_tests.html?script/couch_tests.js"},
>          {'User-Agent',"Mozilla/5.0 (compatible; Konqueror/4.4; Linux)
> KHTML/4.4.5 (like Gecko)"},
>          {"X-Couch-Full-Commit","false"}]
>
> [Fri, 05 Nov 2010 11:37:52 GMT] [debug] [<0.111.0>] OAuth Params: []
>
> [Fri, 05 Nov 2010 11:37:52 GMT] [debug] [<0.111.0>] Minor error in HTTP
> request: {not_found,no_db_file}
>
> [Fri, 05 Nov 2010 11:37:52 GMT] [debug] [<0.111.0>] Stacktrace:
> [{couch_httpd_db,do_db_req,2},
>             {couch_httpd,handle_request_int,5},
>             {mochiweb_http,headers,5},
>             {proc_lib,init_p_do_apply,3}]
>
> [Fri, 05 Nov 2010 11:37:52 GMT] [info] [<0.111.0>] 127.0.0.1 - - 'GET'
> /test_suite_db/ 404
>
> [Fri, 05 Nov 2010 11:37:52 GMT] [debug] [<0.111.0>] httpd 404 error
> response:
>  {"error":"not_found","reason":"no_db_file"}
>
> and all the tests then fail with no_db_file.
>
> Any ideas?
>
> David
>

Mime
View raw message