couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Goodenough <david.goodeno...@btconnect.com>
Subject Re: Tests fail on fresh install
Date Wed, 27 Oct 2010 11:32:15 GMT
I get the same when I install on a Debian sid system.  Although the
most recent version is 0.11.0.  I think that the Debian and Ubuntu
packages come from the the same place.  I get a reason "no_db_file" 
error "not_found" for all the tests.

David

On Wednesday 27 October 2010, Roger Moffatt wrote:
> I'm new to Couchdb and have finally built a test environment as
> follows (steps omitted for brevity, but it shows the core elements)
> 
> Platform is Amazon EC2 micro instance - Ubuntu 10.04 LTS (official
> canonical AMI) upgraded to Maverick 10.10
> 
> I tried to use the package installed by apt-get install couchdb, but
> although that installs 1.01, Futon is severely broken and won't work
> 
> :-(
> 
> So I built from source using;
> 
> 1) sudo apt-get build-dep couchdb
> 2) wget
> http://www.apache.org/dist//couchdb/1.0.1/apache-couchdb-1.0.1.tar.gz 3)
> ./configure --prefix=/usr/local
> --with-js-lib=/usr/lib/xulrunner-devel-1.9.2.10/lib
> --with-js-include=/usr/lib/xulrunner-devel-1.9.2.10/include
> 
> All the test suite tests pass - except one which ALWAYS fails (stats)
> with the error # Assertion 'triggered, "We managed to force a
> all_dbs_active error."' failed: We managed to force a all_dbs_active
> error.
> 
> This fails with Firefox and Chrome.
> 
> My config files are all in the defaults - and from looking at the
> script, the stats code tries to create 10 databases so I'm a bit
> concerned if this triggering a limit somehow - that's rather small.
> 
> I've seen various other threads about this, but nothing conclusive.
> 
> What does this problem suggest? Is there a system configuration I need
> to change? Is the fact that this is running on Amazon EBS a problem
> (hope not, MySQL manages fine)?
> 
> Any ideas?
> 
> Thanks
> Roger


Mime
View raw message