couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Davis <paul.joseph.da...@gmail.com>
Subject Re: old db version number showing up in names-> unreadable docs
Date Thu, 23 Sep 2010 18:26:33 GMT
Right, no idea what couch.uri is, but to fix it you should just need
to move what's in the 0.10.0 up one directory. If there's nothing in
that directory you can just delete it.

On Thu, Sep 23, 2010 at 2:14 PM, Dan Himes <dhimes@vlesolutions.com> wrote:
> /var/lib/couchdb:
> 0.10.0  couch.uri  _users.couch
>
> It looks like it made a "back-up" directory 0.10.0 of the existing
> databases (that's what's in 0.10.0 directory)
>
> On Thu, 2010-09-23 at 13:52 -0400, Paul Davis wrote:
>
>> What do you see in /var/lib/couchdb then?
>>
>> On Thu, Sep 23, 2010 at 12:39 PM, Dan Himes <dhimes@vlesolutions.com> wrote:
>> > Thank you so much for your time, Paul.  I am trying to be clear and
>> > specific for those whom may follow...
>> >
>> > In /etc/couchdb/default.ini I have:
>> >
>> > [couchdb]
>> > database_dir = /var/lib/couchdb
>> > view_index_dir = /var/lib/couchdb
>> > util_driver_dir = /lib/couchdb/erlang/lib/couch-1.0.1/priv/lib
>> > ...
>> >
>> > This makes me think that everything "just worked" when following the
>> > installation instructions.  Sheer luck, though:  I unpacked everything
>> > in /home/dhimes/apache-couch* and did as instructed (I found nothing
>> > telling me to unpack the tarball to any specific directory).
>> >
>> >
>> > On Thu, 2010-09-23 at 12:22 -0400, Paul Davis wrote:
>> >
>> >> Check what's in /etc/couchdb/default.ini to see if its pointing at a
>> >> funny directory. Also, when you installed, did you make sure and
>> >> change install paths? Or did your new ini get installed to
>> >> /usr/local/etc/couchdb/default.ini?
>> >>
>> >> HTH,
>> >> Paul Davis
>> >>
>> >> On Thu, Sep 23, 2010 at 12:16 PM, Dan Himes <dhimes@vlesolutions.com>
wrote:
>> >> > Thanks, Paul.
>> >> >
>> >> > /etc/init.d/couchdb stop
>> >> > attempted to reload futon, but reload failed so couchdb was stopped
>> >> >
>> >> >  I did command you indicated with "cp" instead of "mv" (and didn't
>> >> > delete)
>> >> >
>> >> > /etc/init.d/couchdb start
>> >> >
>> >> > reload futon successful,  but futon is still pointing to /0.10.0/
>> >> > directory.
>> >> >
>> >> > Tried to "configure," but says I'm not a server admin.  I am, but
now
>> >> > need to see how to tell futon.  I didn't run into this before, but
maybe
>> >> > I just didn't get that far.  I had set myself up in couchdb 0.10.0
as a
>> >> > db admin, but not a server admin.  Old dbadmin credentials don't appear
>> >> > to be recognized as login is hanging.
>> >> >
>> >> > On Thu, 2010-09-23 at 11:58 -0400, Paul Davis wrote:
>> >> >
>> >> >> Most odd.
>> >> >>
>> >> >> Sounds like a config changed from the previous version. Ie, the
db
>> >> >> path went from:
>> >> >>
>> >> >> /path/to/dbs/0.10.0/
>> >> >>
>> >> >> to
>> >> >>
>> >> >> /path/to/dbs/
>> >> >>
>> >> >> Which isn't out of this world unbelievable. To fix it, just do:
>> >> >>
>> >> >> sudo mv /path/to/dbs/0.10.0/* /path/to/dbs/ && rmdir /path/to/dbs/0.10.0/
>> >> >>
>> >> >> Make sure couchdb is stopped when you do that to avoid other funny
errors.
>> >> >>
>> >> >> Also, make sure to have a backup if you're not comfortable moving
>> >> >> datafiles around on the command line.
>> >> >>
>> >> >> Paul
>> >> >>
>> >> >> On Thu, Sep 23, 2010 at 11:47 AM, Dan Himes <dhimes@vlesolutions.com>
wrote:
>> >> >> > Hello,
>> >> >> >
>> >> >> > I'm brand new, but I couldn't find a reference to this problem.
 I had
>> >> >> > the ubuntu package couchdb 0.10 installed, but recently moved
to 1.0.1
>> >> >> > by installing from source following the guide here:
>> >> >> > http://wiki.apache.org/couchdb/Installing_on_Ubuntu).  However,
futon
>> >> >> > now shows the database as 0.10.0/dbname (for example,
>> >> >> > 0.10.0/hello-world), and when I click on it I get the error:
>> >> >> >
>> >> >> > +++
>> >> >> > Error: illegal_database_name
>> >> >> >
>> >> >> > Only lowercase characters (a-z), digits (0-9), and any of
the characters
>> >> >> > _, $, (, ), +, -, and / are allowed. Must begin with a letter.
>> >> >> > +++
>> >> >> >
>> >> >> > I understand what the error means, but not how to move past
it.  Thank
>> >> >> > you for your help!
>> >> >> >
>> >> >> > Best regards,
>> >> >> > Dan
>> >> >> >
>> >> >
>> >> >
>> >> >
>> >> > Daniel E. Himes, Ph.D.
>> >> > President
>> >> > Virtual Learning Environment Solutions, Inc.
>> >> > 4 Bartlett St ~ Marblehead  Massachusetts ~ 01945-2720
>> >> > 781.277.1151
>> >> >
>> >
>> >
>> >
>> > Daniel E. Himes, Ph.D.
>> > President
>> > Virtual Learning Environment Solutions, Inc.
>> > 4 Bartlett St ~ Marblehead  Massachusetts ~ 01945-2720
>> > 781.277.1151
>> >
>
>
>
> Daniel E. Himes, Ph.D.
> President
> Virtual Learning Environment Solutions, Inc.
> 4 Bartlett St ~ Marblehead  Massachusetts ~ 01945-2720
> 781.277.1151
>

Mime
View raw message