couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Somers <petsom...@gmail.com>
Subject Recap: Couchdb crashes on Windows
Date Mon, 27 Sep 2010 08:11:42 GMT
Hi all,

Just to summarize my previous thread, hoping that someone does know the
answer to my problem.
I want to thank everyone that already tried to help me.

We have been using couchdb on Windows without any problems for a while now
in dev an test phases.
Couchdb version 1.0.1, Windows 7 64bit.
Database files where always around 2 GB.
Our project enters productions phase, so I tried to load actual production
data in.
Couchdb always crashes when the database file is exactly 4GB (around 250,000
different documents)!


This is is couchdb's response after 4 GB of data:

Status code:500

{"error":"{{badmatch,{error,enomem}},

[{couch_file,read_raw_iolist_int,3},

{couch_file,handle_call,3},

  {gen_server,handle_msg,5},


{proc_lib,init_p_do_apply,3}]}","reason":"{gen_server,call,[<0.19884.5>,{pread_iolist,4294426050},infinity]}"}

[Sat, 25 Sep 2010 16:59:17 GMT] [error] [<0.227.0>] ** Generic server
<0.227.0> terminating
** Last message in was {pread_iolist,4294943206}
** When Server state ==
{file,{file_descriptor,prim_file,{#Port<0.3730>,680}},
                              0,4295016651}
** Reason for termination ==
** file_corruption

After restart, couchdb keeps crashing as long as the 4 GB db file is there.

Possible solutions from the mailing list
-Use NTFS instead of FAT32: I was already using NTFS
-Check file quota settings: quotas management was disabled
I tried to copy a 5 GB file into the DB folder without any problems
-Run couchdb with the erlang console instead of as service: the same error
occurs
-It could be an Erlang on Windows problem: I hope it is not, they would not
support Couchdb on Windows if this was the case?

Windows event log:
This is what I found in the windows event log:
 - <?ui=2&view=bsp&ver=ohhl4rw8mbn4#12b488d84095eff0_> <Event xmlns="*
http://schemas.microsoft.com/win/2004/08/events/event*">
 - <?ui=2&view=bsp&ver=ohhl4rw8mbn4#12b488d84095eff0_> <System>
   <Provider Name="*Application Error*" />
   <EventID Qualifiers="*0*">1000</EventID>
   <Level>2</Level>
   <Task>100</Task>
   <Keywords>0x80000000000000</Keywords>
   <TimeCreated SystemTime="*2010-09-24T09:50:57.000000000Z*" />
   <EventRecordID>43469</EventRecordID>
   <Channel>Application</Channel>
   <Computer>xxxxxxxx</Computer>
   <Security />
  </System>
 - <?ui=2&view=bsp&ver=ohhl4rw8mbn4#12b488d84095eff0_> <EventData>
   <Data>*erl.exe*</Data>
   <Data>0.0.0.0</Data>
   <Data>4c25a0e8</Data>
   <Data>*beam.smp.dll*</Data>
   <Data>0.0.0.0</Data>
   <Data>4c259ee0</Data>
   <Data>40000015</Data>
   <Data>0001062a</Data>
   <Data>4ac</Data>
   <Data>01cb5bcdbb76622e</Data>
   <Data>C:\Program Files (x86)\Apache Software
Foundation\CouchDB\erts-5.8\bin\erl.exe</Data>
   <Data>C:\PROGRA~2\APACHE~1\CouchDB\erts-5.8\bin\beam.smp.dll</Data>
   <Data>3a3a07c6-c7c1-11df-a821-c9b233f5989f</Data>
  </EventData>
  </Event>


crashdump excerpt:
https://docs.google.com/Doc?docid=0Ac5wgE-Tye0oZGQ2cjU1Z2tfMThkNjl3Yzdnag&hl=nl&authkey=CJfN2pQJ


couchlog excerpt:
https://docs.google.com/document/edit?id=1K_cWU4bwDSPa0UYxF8mOiAwC7-zhTHhWsigUNZHuQdM&hl=nl&authkey=CPCV9vYC

To speed up my tests (to get faster to the 4 GB), I tried to upload big
attachments (800MB) with futon.
Couchdb always crashes during the upload. This may not be related to this
problem.

Thanks,

Peter

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message