couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randall Leeds <randall.le...@gmail.com>
Subject Re: CouchDB Replication Failure - odd db_not_found errors
Date Wed, 04 Aug 2010 19:27:06 GMT
It may be that you just had too many replications spun up at once for
your configuration settings.
Have you read through
http://wiki.apache.org/couchdb/Performance#Resource_Limits ?

On Wed, Aug 4, 2010 at 10:38, Chris Stockton <chrisstocktonaz@gmail.com> wrote:
> Hello,
>
> On Mon, Aug 2, 2010 at 5:49 PM, Chris Stockton
> <chrisstocktonaz@gmail.com> wrote:
>> I am having a strange issue that I am stuck and unsure how to further
>
> For anyone who gets similar errors, I was unable to find root cause
> for this. It seemed to happen when I fired up our replicator, which
> spins up about 4 thousand replication jobs. My only thought is it was
> over-loaded. I ended deleting all dbs, reinstalling couchdb, deleting
> all lib files etc. Basically a fresh couchdb build. I then replicated
> the databases one by one. I spun up the replicator, which basically
> does status checks and makes sure continuous replication is running on
> all machines before I went home last night and despite hours of errors
> they dwindled down until all databases were replicating correctly.
>
> Moral to story, if replication isn't working with similar errors, fix
> might be to wipe all databases, then single pass replicate (or rsync)
> all databases before firing up continuous.
>
> -Chris
>

Mime
View raw message