couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From whims...@aol.com
Subject Re: can't upgrade from .10 to .11
Date Fri, 13 Aug 2010 21:29:41 GMT
no processes are running, but it still doesn't work.

I installed couchio version 1.0 in home/couchdb but I don't know how to start it up.
arrrghhh. I've spent all day on this and still gotten nowhere.
If I install it from the source would that work. Instructions?

Thanks,
Dan

 

 


 

 

-----Original Message-----
From: Sam Bisbee <sam@sbisbee.com>
To: user@couchdb.apache.org
Sent: Fri, Aug 13, 2010 1:37 pm
Subject: Re: can't upgrade from .10 to .11


On Fri, Aug 13, 2010 at 01:24:18PM -0400, whimsica@aol.com wrote:

> I followed your instructions the apt-get upgrade couchdb

> after updating

> and starting couchdb I still get Futon on Apache CouchDB    0.10.0 in the 

lower right corner when going to

> localhost:5984/_utils

> 

> 

> curl http://127.0.0.1:5984/

> gives back

> couchdb welcome version .0.10.0

> 

> So what do I try next.

> Do I have to restart the computer?



I'd recommend stopping couchdb and using `ps` to see if there are any couchdb

processes still running. If there are, then kill them (including the heart

process) or restart the box, and see if you still have this problem.



Context: I/we/Debian patched the init file in release 0.10.1-2, adding a

configurable grace period so that couchdb could stop before the init script

ended (it also added harsher stop instructions to make sure couchdb was really,

REALLY stopped). This was manifesting as a problem when you would uninstall or

upgrade the package - ex., old code from the previous version would still be

running in a process. You would have this patch since, as Noah said, Ubuntu

still pulls couchdb from Debian. But you might be having problems with the

patch.



Cheers,



--

Sam Bisbee

www.sbisbee.com


 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message