couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From peg <gig...@yahoo.fr>
Subject Re: my 1.0 installation on ubuntu lucid fails to start
Date Mon, 19 Jul 2010 10:16:53 GMT
Richard Llewellyn <llewelr@...> writes:

> 
> I found the above messages about 1.0 and ubuntu, and re-installed erlang,
> uninstalled and reinstalled couchdb, and now is starting up.  Haven't
> finished with all the tests yet.
> Thanks,
> Rich
> 

Hi,

On Ubuntu 10.04, same problem, no answers from couchdb daemon.

>sudo /etc/init.d/couchdb start

>curl -X GET http://127.0.0.1:5984
curl: (7) couldn't connect to host

Nothing in log file:
>cat /usr/local/etc/couchdb/couch.ini
...
LogFile=/usr/local/var/log/couchdb/couch.log
...

Tried to uninstall current erlang (ubuntu) version then installed last erlang
version (V 5.8) from sources.
> sudo apt-get remove erlang
then install from sources

Tried to re-installed again couchdb 1.0.0
> sudo apt-get remove couchdb

then install from sources
(./configure --with-erlang=/usr/local/lib/erlang/usr/include/
--with-js-lib=/usr/lib/xulrunner-devel-1.9.2.6/lib
--with-js-include=/usr/lib/xulrunner-devel-1.9.2.6/include)

What coud I do ? 

;-) 







Mime
View raw message