couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alux <alu...@googlemail.com>
Subject Re: How to update to 1.0
Date Tue, 27 Jul 2010 06:06:58 GMT
Thank you Dave,

I will try this today.

Btw, if you use Windows too, I remember the test suite was assumed to  
fail erratically in 0.11 still. I haven't seen anywhere that this has  
changed for 1.0.

Thank you again, alux


Am 26.07.2010 um 22:26 schrieb Dave Cottlehuber <dave@muse.net.nz>:

> Hi Alux
>
> assuming you're installed into %couch% - e.g. c:\program files 
> \CouchDB\
>
> %couch%\etc
> %couch%\var
>
> this is sufficient.
>
> I would recommend you actually backup these files, uninstall CouchDB,
> & then re-install, run test suite, & once OK, move in your DBs and
> your local.ini changes.
>
> This avoids leftover crud such as erts-5.7.3 and R13B02 components.
>
> If you're using the 1.0.0 binary installer there appear to be some
> problems - I've just done the upgrade, my development couch runs fine
> (very low load) but I am getting crashes during test suite for
> example:
> - test suite crashes during delayed_commits & stats
> I'm still working through a fully compiled build to see if I get the
> same issues.
>
> YMMV
>
> cheers
> Dave
>
> On 27 July 2010 02:47, Alux <aluxob@googlemail.com> wrote:
>> Hello,
>>
>> I use CouchDB 0.11.0, and want to update to 1.0, keeping my DBs of  
>> course.
>> To not make it too easy - I have to use Windows XP.
>>
>> Is there any description, or hint I can use?
>>
>> My hypothesis is just to make a backup of config files and
>> ..\var\lib\couchdb  - but I'm not sure.
>>
>> Many thanks, alux
>>

Mime
View raw message