couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Christian <adam.christ...@gmail.com>
Subject Re: .10.1 to .11 Upgrade Pains, ideas?
Date Wed, 05 May 2010 23:55:58 GMT
Thanks so much rming the old version of mochiweb fixed the problem.

Before we do this in production, can you give me any insight into how that
error is caused by the old version of mochiweb? Does it reflect something
about our database, or is it a bug in the old version of mochiweb?

Thanks again so much!

Adam

On Wed, May 5, 2010 at 4:20 PM, Randall Leeds <randall.leeds@gmail.com>wrote:

> Most likely you have an old mochiweb sitting around in
> /usr/lib/couchdb/erlang/lib
>
> Make sure you have completely removed 0.10.1.
>
> On Wed, May 5, 2010 at 16:13, Adam Christian <adam.christian@gmail.com>
> wrote:
> > I'm trying to upgrade our .10.1 server to .11, I can view the DB's in
> futon,
> > but when I start asking them for data with python I get the following TB,
> > any ideas would be greatly appreciated as we are badly needing some of
> the
> > .11 improvements.
> >
> > Thanks in advance!!
> >
> > Adam
> >
> > TB
> > ---
> >
> > Traceback (most recent call last):
> >  File "./beanstalk.py", line 75, in <module>
> >    config = convert_expediter_conf(get_expediter_conf(conf_db))
> >  File "/home/hostess/projects/sauce/lib/couch_models.py", line 44, in
> > get_expediter_conf
> >    amis = list(AMI.view('amis/active')) # simplify usage
> >  File "/usr/local/lib/python2.6/dist-packages/couchdbkit/client.py", line
> > 944, in __len__
> >    return self.count()
> >  File "/usr/local/lib/python2.6/dist-packages/couchdbkit/client.py", line
> > 878, in count
> >    self._fetch_if_needed()
> >  File "/usr/local/lib/python2.6/dist-packages/couchdbkit/client.py", line
> > 909, in _fetch_if_needed
> >    self.fetch()
> >  File "/usr/local/lib/python2.6/dist-packages/couchdbkit/client.py", line
> > 891, in fetch
> >    self._result_cache = self.view._exec(**self.params).json_body
> >  File "/usr/local/lib/python2.6/dist-packages/couchdbkit/client.py", line
> > 979, in _exec
> >    return self._db.res.get(self.view_path, **params)
> >  File "/usr/local/lib/python2.6/dist-packages/restkit/resource.py", line
> > 135, in get
> >    return self.request("GET", path=path, headers=headers, **params)
> >  File "/usr/local/lib/python2.6/dist-packages/couchdbkit/resource.py",
> line
> > 125, in request
> >    payload=body, headers=headers, **params)
> >  File "/usr/local/lib/python2.6/dist-packages/restkit/resource.py", line
> > 245, in request
> >    response=resp)
> > restkit.errors.RequestFailed: {"error":"bad_request","reason":"invalid
> UTF-8
> > JSON"}
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message