couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Goodlad <da...@goodlad.ca>
Subject Re: 0.11 on Ubuntu 10.04 (lucid lynx)
Date Sun, 09 May 2010 22:36:22 GMT
On Sat, May 8, 2010 at 7:29 PM, Julian Moritz <mailings@julianmoritz.de> wrote:
> Hi Jim,
>
> Am 08.05.2010 05:03, schrieb Jim R. Wilson:
>> Quick question - what's the easiest (most relaxing) way to install
>> couchdb 0.11 on Ubuntu lucid lynx?  Should I compile from source?
>> Should I add debian unstable to my sources.list?  Should I just wait?
>>
>
> I'm installing it from source without using libmozjs. Install all the
> packages named in the "INSTALL.Unix" but not the libmozjs, instead I'm
> using the libxulrunner from mozilla.

If, like me, you don't want to bring in all of libxulrunner's
dependencies (x11!) on your server, I'd suggest installing the js lib
from source as well. I have a set of babushka (http://babushka.me/)
deps at http://github.com/dgoodlad/babushka-deps that will get couch
installed from source if you're interested.

Dave

Mime
View raw message