couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Lehnardt <...@apache.org>
Subject Re: Installing couchdb 0.11 on Ubuntu does not work
Date Fri, 02 Apr 2010 16:03:22 GMT

On 2 Apr 2010, at 17:42, Benoit Chesneau wrote:

> On Fri, Apr 2, 2010 at 4:18 PM, Jan Lehnardt <jan@apache.org> wrote:
>> I think in this case he needs to do
>> 
>>    application:start(crypto).
>>    application:start(ibrowse).
>>    application:start(couch).
>> 
>> Only if that fails, it is a hint that the crypto module is missing.
>> 
>> Cheers
>> Jan
>> --
>> 
>> 
> 
> the application:start already handle that ;
> 
> start(_Type, DefaultIniFiles) ->
>    IniFiles = get_ini_files(DefaultIniFiles),
>    case start_apps([crypto, sasl, inets, oauth, ssl, ibrowse, mochiweb]) of
>    ok ->
>        couch_server_sup:start_link(IniFiles);
>    {error, Reason} ->
>        {error, Reason}
>    end.
> 
> - benoit

You're right, I confused that with how the etap tests work.
Julian, can you try installing erlang-crypto.

Cheers
Jan
--


Mime
View raw message