couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j d <dobber1...@gmail.com>
Subject Re: RHEL5.1
Date Wed, 10 Mar 2010 15:12:01 GMT
oops...

On Wed, Mar 10, 2010 at 10:06 AM, j d <dobber1134@gmail.com> wrote:
> Thank you Nils for your persistence and help.
>
> On Wed, Mar 10, 2010 at 9:44 AM, Nils Breunese <N.Breunese@vpro.nl> wrote:
>> j d wrote:
>>
>>> by the way my epel.repo file looks like:
>>> --------------------
>>> [epel]
>>> name=Extra Packages for Enterprise Linux 5 - $basearch
>>> #baseurl=http://download.fedoraproject.org/pub/epel/5/$basearch
>>>
>>> mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-5&arch=$basearch
>>> failovermethod=priority
>>> enabled=1
>>> gpgcheck=1
>>> gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL
>>>
>>> [epel-debuginfo]
>>> name=Extra Packages for Enterprise Linux 5 - $basearch - Debug
>>> #baseurl=http://download.fedoraproject.org/pub/epel/5/$basearch/debug
>>>
>>> mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-debug-5&arch=$basearch
>>> failovermethod=priority
>>> enabled=1
>>> gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL
>>> gpgcheck=1
>>>
>>> [epel-source]
>>> name=Extra Packages for Enterprise Linux 5 - $basearch - Source
>>> #baseurl=http://download.fedoraproject.org/pub/epel/5/SRPMS
>>>
>>> mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-source-5&arch=$basearch
>>> failovermethod=priority
>>> enabled=1
>>> gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-EPEL
>>> gpgcheck=1
>>> ------------------------
>>
>> Yeah, fine. I'd just disable [epel-debuginfo] and [epel-source] again,
>> because you don't need those. But that shouldn't change anything for you
>> right now.
>>
>>> (...)
>>>>
>>>> Error: Missing Dependency: libicu-devel is needed by package couchdb
>>>> ]
>>>>
>>>> thoughts?
>>
>> Your yum setup looks a little broken, possibly because your RHN
>> subscription seems to be expired or something. Which also might explain
>> why you're still on RHEL 5.1 while 5.4 is the current version.
>>
>

Yeah, I inherited this server and I'm sure whatever support and
updating services they paid for are now over.  I didn't think I needed
the RHN, I figured that was only a rpm repo run by Red Hat and that I
just needed to point yum to a free place (like EPEL).  I guess at this
point my only choices are to either update RHEL (hope you can do this
for free if you don't buy support) or to take another 3 days to wipe
the machine and reinstall with another Linux variant.

>
>> Nils Breunese.
>>
>> P.S. I just updated http://wiki.apache.org/couchdb/Installing_on_RHEL5
>> with separate sections for installing a prepackaged CouchDB and
>> installing from source.
>>

Thanks again Nils.

Mime
View raw message