couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Lehnardt <...@apache.org>
Subject Re: get document => unknown_error undef
Date Fri, 19 Mar 2010 06:57:27 GMT
Can you set the log level to debug and show the trace for the config page again?

Cheers
Jan
--

On 18 Mar 2010, at 21:21, John Merrells wrote:

> 
> On Mar 18, 2010, at 5:48 PM, J Chris Anderson wrote:
> 
>> I got the file, and http://localhost:5984/pages/http%3A%2F%2Ffoodbazaar.info%2Frecipes?revs_info=true
works for me on my machine. (current CouchDB trunk and the 0.10.x branch)
>> 
>> It shouldn't be a bad ICU as that is not invoked except by the view collation engine.
>> 
>> I'm not sure what to recommend except upgrading your version of Erlang.
> 
> 
> ok, i moved up...
> 
> root@couchdb:/usr/local/var/log/couchdb# erl +v
> warning: -v (only in debug compiled code)
> Erlang R13B03 (erts-5.7.4) [source] [smp:4:4] [rq:4] [async-threads:0] [kernel-poll:false]
> 
> but still get the same issue... interestingly the futon configuration page causes the
same problem.
> 
> 
> http://127.0.0.1:6095/_utils/config.html
> 
> 
> [Fri, 19 Mar 2010 02:17:52 GMT] [info] [<0.1.0>] Apache CouchDB has started on
http://192.168.147.39:5984/
> 
> [Fri, 19 Mar 2010 02:18:13 GMT] [error] [<0.64.0>] Uncaught error in HTTP request:
{error,undef}
> 
> [Fri, 19 Mar 2010 02:18:13 GMT] [info] [<0.64.0>] Stacktrace: [{xmerl_ucs,from_utf8,
>                        [<<"{couch_httpd_misc_handlers, handle_welcome_req, <<\"Welcome\">>}">>]},
>             {mochijson2,json_encode_string,2},
>             {mochijson2,'-json_encode_proplist/2-fun-0-',3},
>             {lists,foldl,3},
>             {mochijson2,json_encode_proplist,2},
>             {mochijson2,'-json_encode_proplist/2-fun-0-',3},
>             {lists,foldl,3},
>             {mochijson2,json_encode_proplist,2}]
> 
> [Fri, 19 Mar 2010 02:18:13 GMT] [info] [<0.64.0>] 192.168.147.39 - - 'GET' /_config/
500
> 
> [Fri, 19 Mar 2010 02:18:13 GMT] [info] [<0.86.0>] 192.168.147.39 - - 'GET' / 200
> 
> 
> 
> Does this mean that my 'xmerl_ucs' is missing? Maybe that's in an erlang package I didn;t
install or something. How would I check for that?
> 
> John
> 
> 
> 
> -- 
> John Merrells
> http://johnmerrells.com
> +1.415.244.5808
> 
> 
> 
> 
> 
> 


Mime
View raw message