couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thierry Lechat <thie...@lechat.org>
Subject Re: Error trying replicator
Date Fri, 29 Jan 2010 11:08:04 GMT
Ouppss some mistakes in urls: Please use this answer...

Stéphane,

You open Futon from your browser by calling http://ip1:5984/_utils     
Right ? (ie : http://10.0.0.1:5984/mydb  )
You have checked you can access the db using http://server_ip:5984/mydb 
from your browser. (ie http://10.0.0.2:5984/mydb )

Have you checked that server IP1 (ie: 10.0.0.1) is able to communicate 
with server_ip (ie 10.0.0.2) on port 5984  ?
As the replication script runs on IP1 (ie : 10.0.0.1) , it must have 
this access.

Thierry

zecat a écrit :
> Stéphane,
>
> You open Futon from your browser by calling http://ip1:5984/_utils     
> Right ? (ie : http://10.0.0.1:5984/mydb  )
> You have checked you can access the db using 
> http://server_ip:5984/mydb from your browser. (ie 
> http://10.0.0.2:5984/mydb )
>
> Have you checked that server IP1 (ie: 10.0.0.1) is able to communicate 
> with server_ip (ie 10.0.0.2) on port 5984  ?
> As the replication script runs on IP1 (ie : 10.0.0.1) , it must have 
> this access.
>
> Thierry
>
> Stéphane Mourey a écrit :
>> Hi Thierry,
>>
>> Many thanks for your quick answer.
>> Butit it's still not working.
>> Same javascript alert.
>> The log said:
>> [Fri, 29 Jan 2010 10:36:15 GMT] [error] [<0.3117.0>] 
>> {error_report,<0.24.0>,
>>     {<0.3117.0>,crash_report,
>>      [[{initial_call,{couch_rep,init,['Argument__1']}},
>>        {pid,<0.3117.0>},
>>        {registered_name,[]},
>>        {error_info,
>>            {exit,
>>                {db_not_found,<<"http://server_ip:5984/mydb/">>},
>>                [{gen_server,init_it,6},{proc_lib,init_p_do_apply,3}]}},
>>        {ancestors,
>>            
>> [couch_rep_sup,couch_primary_services,couch_server_sup,<0.1.0>]},
>>        {messages,[]},
>>        {links,[<0.43.0>]},
>>        {dictionary,[]},
>>        {trap_exit,true},
>>        {status,running},
>>        {heap_size,1597},
>>        {stack_size,24},
>>        {reductions,473}],
>>       []]}}
>>
>> [Fri, 29 Jan 2010 10:36:15 GMT] [info] [<0.3064.0>] 127.0.0.1 - - 
>> 'POST' /_replicate 404
>>
>> I've checked I can access the db using http://server_ip:5984/mydb 
>> from my browser.
>>
>> Any idears, guys?
>>
>> Best regards,
>>
>> Stephane
>>
>>
>> 2010/1/29 zecat <couchdb@lechat.org <mailto:couchdb@lechat.org>>
>>
>>     Hi,
>>
>>     I have experimented this trouble during two days, until I found
>>     that replication (_replicate) is not able to work with hostname in
>>     from or target field.
>>
>>     Try only with IP address and you will see that replication is
>>     working very well as expected (-;
>>
>>
>>     Thierry
>>
>>     Stéphane Mourey a écrit :
>>
>>         Hi everybody,
>>
>>         I've start to work with Couch just a month ago, and I'm very
>>         enthousiastic
>>         about it.
>>         I'm working on my desktop for development purposes. Now I'm
>>         trying to
>>         replicate my local db on our server.
>>         Both Couchdb server seems to work correctly. I can access
>>         http://127.0.0.1:5984/_utils/database.html?mydb,
>>         http://127.0.0.1:5984/mydb,
>>         http://myserver:5984/_utils/database.html?mydb,
>>         http://myserver:5984/mydbwith my browser, and can add
>>         documents from
>>
>>         Futon. mydb is empty on the
>>         server, and I'm trying to replicate datas from the local db to
>>         the server.
>>         For this, I use the Replicator function from Futon on my
>>         localhost. I did
>>         not try from the server, as incomming connections are not
>>         allowed on my lan.
>>         I got this JavaScript alertbox: "Replication failed: could not
>>         open
>>         http://myserver:5984/mydb/".
>>         In the log: I found:
>>         Fri, 29 Jan 2010 08:33:10 GMT] [error] [<0.1851.0>]
>>         {error_report,<0.24.0>,
>>            {<0.1851.0>,crash_report,
>>             [[{initial_call,{couch_rep,init,['Argument__1']}},
>>               {pid,<0.1851.0>},
>>               {registered_name,[]},
>>               {error_info,
>>                   {exit,
>>                       {db_not_found,<<"http://myserver:5984/mydb/">>},
>>                              
>> [{gen_server,init_it,6},{proc_lib,init_p_do_apply,3}]}},
>>               {ancestors,
>>                          
>> [couch_rep_sup,couch_primary_services,couch_server_sup,<0.1.0>]},
>>               {messages,[]},
>>               {links,[<0.43.0>]},
>>               {dictionary,[]},
>>               {trap_exit,true},
>>               {status,running},
>>               {heap_size,1597},
>>               {stack_size,24},
>>               {reductions,460}],
>>              []]}}
>>
>>         [Fri, 29 Jan 2010 08:33:10 GMT] [info] [<0.1282.0>] 127.0.0.1
>>         - - 'POST'
>>         /_replicate 404
>>         I googled a while, but did not find anything helpfull for the
>>         moment.
>>         Can anyone told what's wrong with this?
>>
>>         Best regards,
>>
>>         Stephane Mourey
>>
>>         
>>
>

Mime
View raw message