couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Bronson <jabron...@gmail.com>
Subject Re: 0.9 -> 0.10 view migration
Date Wed, 20 Jan 2010 21:42:55 GMT
On Tue, Jan 19, 2010 at 6:39 PM, Joshua Bronson <jabronson@gmail.com> wrote:

> On Tue, Jan 19, 2010 at 5:36 PM, Joshua Bronson <jabronson@gmail.com>wrote:
>
>> we're going to give
>> http://github.com/kocolosk/couchdb/tree/0.9.2-and-view-compaction a shot
>>
>
> Uh oh, I just installed this branch, took down our system couch (0.9.0),
> got 0.9.2-and-view-compaction up and running (pointing at our live data),
> and browsed to a view in Futon, but no results. I checked the status page
> and the view group indexer is running. I expected to still be able to access
> the uncompacted views while couch was writing out the compacted ones. Did I
> misunderstand, Adam?
>

I looked in the logs to try to see what happened and put my findings up at
http://pylonshq.com/pasties/471b8769f43ceacd0999cfbc4c1355ef (annotations
underneath the excerpt).

I tried reproducing this behavior on a sandbox server (started a
0.9.2-and-v-c couch with a copy of 0.9.0 data and then browsed around in
Futon) but I could not get it to trigger the erroneous view reindex.
Triggering the view compaction via curl worked as expected.

I was, however, able to reproduce this when I tried reading the data back
from an 0.9.0 couch:

$ curl localhost:5984/melkjug  # (the live db)
> {"error":"error","reason":"{{badmatch,unknown_header_type},\n
> [{couch_db_updater,init,1},\n  {gen_server,init_it,6},\n
>  {proc_lib,init_p_do_apply,3}]}"}
>

See http://pylonshq.com/pasties/07ebe42c7a75af52e9da701a79779fbd

Hope this helps,
Josh

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message