couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benoit Chesneau <bchesn...@gmail.com>
Subject Re: libmozjs-dev conflict in Karmic
Date Sat, 07 Nov 2009 23:00:16 GMT
On Sat, Nov 7, 2009 at 11:18 PM, Brian Candler <B.Candler@pobox.com> wrote:
> On Fri, Nov 06, 2009 at 11:28:37AM +0000, Matt Goodall wrote:
>> This works: http://mattgoodall.blogspot.com/2009/09/build-couchdb-on-ubuntu-910-karmic.html.
>
> Thanks. I see that installing xulrunner-dev also installs libnspr4-dev as a
> dependency, just as libmozjs-dev does, so that eliminates one problem,
>
> What I don't understand is that libmozjs-dev is causing a conflict, but
> libmozjs itself isn't. I was able to build couchdb like this:
>
> * apt-get install libmozjs-dev        (removes firefox as side effect)
> * ... normal build...
> * apt-get install firefox             (removes libmozjs-dev as side effect)
>
>> Can anyone else suggest a better way?
>
> It's annoying to have to set LD_LIBRARY_PATH on each run. Setting
> LD_RUN_PATH at compile time should build that information into the binary,
> but I'll need to test.
>

You coudl apply this patch :
http://bazaar.launchpad.net/%7Eubuntu-branches/ubuntu/karmic/couchdb/karmic/annotate/head%3A/debian/patches/mozjs1.9_ldlibpath.patch


and then build against xulrunner. So you won't have to have LD* in
your .profile. Though it is quite similar.

- benoit

Mime
View raw message