couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Larry <larryr...@gmail.com>
Subject Re: Best way to upgrade from 0.9.1 to 0.10.0
Date Tue, 03 Nov 2009 19:23:02 GMT
Great, Thanks for the tip.

Also for anyone else out there that may be upgrading, I am running Debian 5
(lenny) and the latest Erlang package will not work with 0.10.0 so you need
to build it from source (erlang.org). Things went smoothly for my by doing:


   1. remove $PREFIX/lib/couchdb (for me /usr/local/lib/couchdb/)
   2. apt-get build-dep couchdb erlang
   3. Erlang: download, unpack, configure, make && make install
   4. CouchDB: download, unpack, configure, make && make install




On Tue, Nov 3, 2009 at 10:46 AM, Paul Davis <paul.joseph.davis@gmail.com>wrote:

> Larry,
>
> You should remove the $PREFIX/lib/couchdb directory before make
> install. Theoretically installing over top should work except Erlang
> collates 0.9.0 to be a more recent version that 0.11.0 which causes
> weird errors.
>
> Paul Davis
>
> On Tue, Nov 3, 2009 at 12:22 PM, Larry <larry@lroot.com> wrote:
> > Assuming I have the breaking
> > changes<http://wiki.apache.org/couchdb/Breaking_changes>handled in my
> > app, when I upgrade the actual server to 0.10.0 can I just run
> > the configure, make & make install right on top of the current 0.9.1
> > install? Should I preform some sort of uninstall first?
> >
> > Thanks
> >
> > larry
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message