couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Leek <>
Subject Re: CouchDB doesn't work for me, not even 0.10
Date Fri, 06 Nov 2009 00:11:45 GMT

> The erlang guys might have far more to contribute from that dumpfile 
> but the error message appears to be that the server is looking for the 
> config directories and can't access it because they don't exist or 
> permissions are wrong and the couchdb user can't see it.
> Create or chmod those directories and put your cinfig files there if 
> not already and see if it starts. It's possible that other directories 
> might be missing or misconfigured (perhaps from past installation), so 
> might want to start from scratch and re-install clean.

Well, I've tried a number of things, perhaps you could tell me a little 
more about what I need to do with the config files?  I tried 'make dev' 
and running with utils/run, but it crashes in the same way.  I can't 
seem to find anything that tells it where to look for config files.  On 
the installed copy they seem to be placed in $prefix/etc.  My prefix is 

$ cd /siscnas/scratch/leek2/cdb10/etc/couchdb
$ ls
default.d  default.ini  local.d  local.ini  local.ini~

All this stuff is owned by me, and couchdb is run by me, so I can't see 
how it could be a permissions issue.  (I'm not root of course.)

I'm totally stymied. 


View raw message