couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Candler <B.Cand...@pobox.com>
Subject libmozjs-dev conflict in Karmic
Date Fri, 06 Nov 2009 11:16:12 GMT
I have updated my laptop from Xubuntu Jaunty to Karmic.

I now find that if I install the libmozjs-dev package, required to build
couchdb, it insists on uninstalling Firefox. This is rather annoying.

$ sudo apt-get install libmozjs-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libnspr4-dev
The following packages will be REMOVED
  firefox firefox-3.5 firefox-3.5-branding ubufox xulrunner-1.9.1
The following NEW packages will be installed
  libmozjs-dev libnspr4-dev
0 upgraded, 2 newly installed, 5 to remove and 0 not upgraded.
Need to get 0B/466kB of archives.
After this operation, 24.0MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.

Is anybody else seeing this? Is it the same with a fresh Karmic install, or
just an artefact of the upgrade process?

And is there someone here who knows enough about dpkg dependencies to work
out what the problem is? I can show some info but I can't see any obvious
conflicts.

$ apt-cache showpkg libmozjs-dev
Package: libmozjs-dev
Versions: 
1.8.1.16+nobinonly-0ubuntu1 (/var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_karmic_universe_binary-i386_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_karmic_universe_binary-i386_Packages
                  MD5: b123ef11961280a2acecade73e16ccbd


Reverse Depends: 
  xulrunner-1.9.1,libmozjs-dev
  libxul-dev,libmozjs-dev 1.8.1.16+nobinonly-0ubuntu1
  libsablot0-dev,libmozjs-dev
  xulrunner-1.9.1,libmozjs-dev
Dependencies: 
1.8.1.16+nobinonly-0ubuntu1 - libmozjs0d (2 1.8.1.16+nobinonly) libnspr4-dev (0 (null)) mozilla-browser
(3 2:1.8) 
Provides: 
1.8.1.16+nobinonly-0ubuntu1 - 
Reverse Provides: 

$ apt-cache showpkg libnspr4-dev
Package: libnspr4-dev
Versions: 
4.8-0ubuntu1 (/var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_karmic_main_binary-i386_Packages)
 Description Language: 
                 File: /var/lib/apt/lists/gb.archive.ubuntu.com_ubuntu_dists_karmic_main_binary-i386_Packages
                  MD5: 5fb64e5ffcd6242fc78f56e991c9d6df


Reverse Depends: 
  xulrunner-1.9.1-dev,libnspr4-dev
  libxul-dev,libnspr4-dev
  libmozjs-dev,libnspr4-dev
  xulrunner-1.9.1-dev,libnspr4-dev
  libnss3-dev,libnspr4-dev
  libnspr4-0d,libnspr4-dev 4.7.1+1.9-0ubuntu2
  libnspr4-0d,libnspr4-dev 4.7.1+1.9-0ubuntu2
  libedataserver1.2-dev,libnspr4-dev
Dependencies: 
4.8-0ubuntu1 - libnspr4-0d (2 4.8) libnspr4-0d (1 4.8-0ubuntu1.1~) libnspr-dev (0 (null))
libnspr4 (0 (null)) nvu-dev (0 (null)) 
Provides: 
4.8-0ubuntu1 - 
Reverse Provides: 

Thanks,

Brian.

Mime
View raw message