couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryan Fink <>
Subject libjpeg dependency?
Date Thu, 15 Oct 2009 15:36:30 GMT
Hi.  I'm trying to play with CouchDB on my Mac (10.5.8), Erlang/OTP
R13B02 installed.  I'm getting an error when I try to start couchdb,

$ couchdb
dyld: Symbol not found: __cg_jpeg_resync_to_restart
  Referenced from:
  Expected in: /opt/local/lib/libJPEG.dylib

Trace/BPT trap

The same error occurs with both couchdb-0.9.1 and -0.10, each compiled
from source tarball.

So, I have two questions:

1. Why does couchdb depend on libjpeg?

2. Is there any way to disable couchdb's dependency on libjpeg?  (Or,
of course, fix the dependency in some other way, but I've had macports
churning for a while now upgrading everything, and I'm ready to be

More details:

$ ls -l /opt/local/lib/libJPEG.dylib
lrwxr-xr-x  1 root  admin  20 Oct 15 09:27
/opt/local/lib/libJPEG.dylib -> libjpeg.62.0.0.dylib
$ ls -l /opt/local/lib/libjpeg.62.0.0.dylib
-rwxr-xr-x  2 root  admin  139616 Oct 15 09:27

$ port info jpeg
jpeg @6b, Revision 3 (graphics)

I've tried the various DYLD_LIBRARY_PATH workarounds that Google turns
up, but they don't make any difference.


View raw message