couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Davis <paul.joseph.da...@gmail.com>
Subject Re: I can’t relax. I broke my couch upgrading dependencies. What might this error mean?
Date Sun, 02 Aug 2009 07:13:06 GMT
Looks like libnspr got upgraded but couch_erl_driver isn't linking
against the new version.

Try 'make clean && make' in your couchdb directory to make sure
everything gets rebuilt and relinked.

Also, try 'nspr-config --version' to make sure it's still installed
and ports didn't choke when upgrading or something funky.

HTH,
Paul Davis

On Sun, Aug 2, 2009 at 3:08 AM, Oliver Boermans<boermans@gmail.com> wrote:
> Hi all, hope you are having a relaxing weekend.
> I upgraded my couchdb to 0.9.1 (from 0.9.0) it worked mostly. One test
> was failing in futon (replication), so in an effort to be thorough, I
> upgraded a handful of dependencies which macports reported as
> upgradable. Something in this process broke; After rebuilding and
> installing it, couchdb will no longer launch,
>
> Specifically I am attempting to launch couchdb with:
> sudo -i -u couchdb couchdb
>
> the first line in response says:
> unable to change directory to  /usr/local/var/lib/couchdb: No such
> file or directory
>
> This directory does exist, just a moment earlier I set permissions on it:
> sudo chown -R couchdb:couchdb /usr/local/var/lib/couchdb
>
> anyway, continuing from the response from my attempt to launch
> couchdb, there are a bunch more permission and code_server errors
> which are concluded with:
> Apache CouchDB 0.9.1 (LogLevel=info) is starting.
> {"init terminating in
> do_boot","dlopen(/usr/local/lib/couchdb/erlang/lib/couch-0.9.1/priv/lib/couch_erl_driver.so,
> 2): Library not loaded: /opt/local/lib/libnspr4.dylib\n  Referenced
> from: /opt/local/lib/nspr/libplds4.dylib\n  Reason: image not found"}
>
> I understand that my problem is most likely not couchdb specific, I
> would appreciate any pointers while I save up for an Intel Mac to
> replace my ageing PPC so I can run CouchDBX whose installation and
> maintenance is more inline with my command line challenged skill set.
>
> I have tried uninstalling and reinstalling erlang with macports
> without any change. I’m open to the idea of cleaning out couchdb’s
> dependencies to reinstall them from scratch, but I’m hoping you guys
> might be able to suggest an approach that might be a little less time
> consuming.
>
> Alternatively time machine is operational on my Mac, but I don’t know
> where to point it to roll back my macports updates.
>
> Thanks in advance.
> Ollie
>

Mime
View raw message