couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael McCaffrey" <mmccaff...@ittvis.com>
Subject RE: Can't run views on new install
Date Thu, 06 Aug 2009 15:10:40 GMT
Well, don't know what happened but now it is working.

I tried to install a new version from the Virginia site, couchdb-091.exe, and it wouldn't
start up at all.

Then tried to run the couch_js.exe. It didn't fail but didn't produce any output. 

Went back to my original install and it is now working and I can run a view.

Maybe manually executing the couch_js.exe resolved some issue.

An "official" windows version would be nice.

Thanks for the support.

Mike 

-----Original Message-----
From: Brunjes, Lee (lmb7s) [mailto:lmb7s@virginia.edu] 
Sent: Thursday, August 06, 2009 6:47 AM
To: user@couchdb.apache.org
Subject: RE: Can't run views on new install

I ran into this Tuesday, thought it was a badly built spider monkey library, but it ended
up being a config issue for me.

I would check that you can load the spider monkey library, just run couch_js.exe, At some
point in playing with it I got a bad copy that simply wouldn't load.

Then make sure the following lines are *not* included/ uncommented in your default.ini file,
probably in c:\programfiles\erl5.7.2\bin

[query_servers]
javascript = %bindir%/%couchjs_command_name% %localdatadir%/server/main.js

-Lee


-----Original Message-----
From: jchris@gmail.com [mailto:jchris@gmail.com] On Behalf Of Chris Anderson
Sent: Wednesday, August 05, 2009 7:04 PM
To: user@couchdb.apache.org
Subject: Re: Can't run views on new install

On Wed, Aug 5, 2009 at 12:36 PM, Michael McCaffrey<mmccaffrey@ittvis.com> wrote:
> New to couchDB.
>
>
>
> Got a small java app reading and writing documents to the db using
> couchdb4j.
>
>
>
> However, I can't get views to work.  Get this error when I try to run a
> view. Get the error both in java and on futon.
>
>
>
> View is simple to return all docs
>
>
>
> function(doc) {emit(null,doc);}
>
>
>
>
>
> Error: badmatch
>
>
>
> {{einval,[{erlang,open_port,
>
>                  [{spawn,"couch_js
> ../lib/couchdb/share/server/main.js"},
>
>                   [stream,{line,1024},binary,exit_status,hide]]},
>
>          {couch_os_process,init,1},
>
>          {gen_server,init_it,6},
>
>          {proc_lib,init_p_do_apply,3}]},
>
>  {gen_server,call,[couch_query_servers,{get_proc,<<"javascript">>}]}}
>
>
>
> Running on windows/Firefox.
>

The Windows process model is a bit different from posix, so that's
probably why spawning the JavaScript process is failing. There is a
windows installer in the works. Maybe someone who knows more about it
can comment.

Chris

>
>
>
>
> Any help?
>
>
>
> Thanks
>
>
>
>



-- 
Chris Anderson
http://jchrisa.net
http://couch.io

Mime
View raw message