couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Deja <madocd...@gmail.com>
Subject Re: Only getting "eacces" after port install on Mac OS X
Date Sun, 26 Apr 2009 00:44:48 GMT
One more remark before I go to bed: I created a test database when I  
ran couchdb as root, then started couchdb with the couchdb user. Now,  
I cannot even see the database that I created as root. However, when  
launching couchdb as root again, the database is visible in Futon.

Am 26.04.2009 um 02:28 schrieb Matthias Deja:

> Hello Paul,
>
> thanks for the quick response. You are correct about the location of  
> couchdb on Mac OS. Unfortunately, the error stays the same on my  
> system.
>
> I ran the chown, which did not help. Also, I checked the config file  
> under:
>
> /opt/local/Library/LaunchDaemons/org.apache.couchdb.plist
> (Is there another CouchDB init file anywhere?) - This file seems to  
> contain all the right paths.
>
> In order to find out if CouchDB runs under the right user, I did:
>
> <<<
> Nova:lib madoc$ ps -U couchdb
>  PID   TT  STAT      TIME COMMAND
>  622   ??  SNs    0:00.20 /System/Library/Frameworks/ 
> CoreServices.framework/Frameworks/Metadata.fr
>  626   ??  Ss     0:00.76 /opt/local/lib/erlang/erts-5.6.5/bin/beam - 
> Bd -K true -- -root /opt/loca
> >>>
>
> Looks oky to me.
>
> I also restarted the service. But the error stays the same on my  
> system.
>
> By the way: The CouchDB lib directory (/opt/local/var/lib/couchdb)  
> is empty, except for .turd_couchdb. Shall it be this way?
>
> Thanks,
> Madoc.
>
> Am 26.04.2009 um 01:52 schrieb Paul Davis:
>
>> Madoc,
>>
>> From what you describe it sounds very much like the couchdb user is
>> unable to write to the lib directory. I'm not extensively familiar
>> with the ports version, but you'll want to make sure that the lib
>> directory is writable by the user running couchdb. I know you said
>> that you changed the owner but some things to double check:
>>
>> My guess is that the couchdb lib directory for a port installed
>> version is at /opt/local/lib/couchdb
>>
>> You need to make sure that this directory has write permissions for
>> the user running couchdb. You might want to try something like:
>>
>>   $ sudo chown -R couchdb:couchdb /opt/local/lib/couchdb
>>
>> Also, you can check the ini files for the root directory to make sure
>> that the lib direcotry is /op/local/lib/couchdb if things are still
>> broken. Also, you can double check that the beam process is running  
>> as
>> the couchdb user with top.
>>
>> Other than that, I haven't got many pointers, but seeing as couchdb
>> starts and you can visit futon this definitely sounds like a weird
>> permissions error.
>>
>> HTH,
>> Paul Davis
>>
>> On Sat, Apr 25, 2009 at 7:36 PM, Matthias Deja  
>> <madocdoyu@gmail.com> wrote:
>>> Hello,
>>>
>>> I installed CouchDB just a few minutes ago on my MacOS X 10.5  
>>> system. As
>>> documented in the CouchDB Wiki, I used "port" to install CouchDB.
>>>
>>> CouchDB is started, and I can use Futon on my web browser.  
>>> However, on all
>>> tests from the test suite and when trying to create a database, I  
>>> get an
>>> "eacces" error message.
>>>
>>> Probably the error is simple to solve, but I do not know how.  
>>> Please help
>>> me. I already tried rebooting (no manual starting of CouchDB was  
>>> required,
>>> because I installed it as a service), and I tried changing the  
>>> owner of the
>>> CouchDB log and lib directories to "couchdb". The error message  
>>> stays the
>>> same.
>>>
>>> My knowledge of Unix is present, but very limited. However, if You  
>>> tell me
>>> which commands to enter, I will do so and send You the result.
>>>
>>> Thanks very much!
>>> Madoc.
>>>
>


Mime
View raw message