couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Goodenough <>
Subject Re: Error creating a database with Debian CouchDb (0.9.0)
Date Sun, 19 Apr 2009 16:07:35 GMT
On Saturday 18 April 2009, David Goodenough wrote:
> I am a newbie to CouchDb, and so I installed the Debian sid couchdb
> package and fired up my browser.  I pointed it at the _utils URL, and
> up came the admin panel.
> Then I clicked on Create Database, and it popped up a dialog asking
> for a new database name.  I filled in a name (experiment as it happens)
> and I got the wonderfully helpful error message "Missing".
> Any idea how to proceed?
> David

Having sorted out my configuration, I still get the Missing response.  This
is when I try to access CouchDb with Konqueror.  Well I know that Konqueror
is not always fully supported, so I tried with Firefox, and it works.  So I
guess that this is a Konqueror problem.  Is there browser specific code 
in CouchDb, and if so where.  

The most obvious difference is that the request that goes across seems
to be marked as "GET /experiment/ {1,1}" which gets rejected, but with
Firefox it logs "GET /_utils/ {1,1}".  So I guess that either the Javascript
code or the browser itself is getting the request wrong.  The rest of the 
headers looks reasonable.


View raw message