couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Lehnardt <>
Subject Re: Getting "unauthorized" errors replicating from jchris's twitter-client-design
Date Sun, 15 Feb 2009 10:01:00 GMT
Quick guess:

Chris has set up his instance so that we all can read, but only
he can write to it. At the moment, replication does not fully
work with authentication-enabled replication sources. But
this is being worked on.

The book is describing reality for when it is going to be
released. Some things we write about might not yet work
as described.


On 15 Feb 2009, at 05:16, Jens Alfke wrote:

> Hi -- I've just gotten CouchDB installed (SVN trunk r743373, OS X  
> 10.5.6, dependencies installed via DarwinPorts). The test suite  
> passes, and a couple of the simple examples from the O'Reilly book- 
> in-progress work, but when I try to replicate the Twitter client as  
> described in jchris's "My Couch Or Yours" blog post, I keep getting  
> errors.
> Actually the Replicator in the Futon interface doesn't show  
> anything, it just never stops the spinny progress indicator. But  
> this immediately gets dumped to the log file:
> [Sun, 15 Feb 2009 03:58:57 GMT] [error] [emulator] Error in process  
> <0.214.0> with exit value: {{nocatch,{unauthorized,<<39 bytes>>}},

> [{couch_db,validate_doc_update,3},{couch_db,'-update_docs/4-lc 
> $^1/1-8-',2},{lists,zipwith,3},{couch_db,update_docs,4}, 
> {couch_rep,save_docs_buffer,3}]}
> [Sun, 15 Feb 2009 03:58:57 GMT] [error] [<0.49.0>]  
> {error_report,<0.22.0>,
>    {<0.49.0>,std_error,
>     {mochiweb_socket_server,235,
>         {child_error,
>             {{nocatch,
>                  {unauthorized,
>                      <<"You are not a server or database admin.">>}},
>              [{couch_db,validate_doc_update,3},
>               {couch_db,'-update_docs/4-lc$^1/1-8-',2},
>               {lists,zipwith,3},
>               {couch_db,update_docs,4},
>               {couch_rep,save_docs_buffer,3}]}}}}}
> Looks like some sort of permissions problem. I have, as advised in  
> the installation instructions, added an admin account to the  
> local.ini setup. But I've logged in with that account in the browser  
> (I've tried both Safari and Firefox) and I can create db's and  
> documents via the web interface. Is there a specific problem with  
> replication and admin access?
> Thanks,
> —Jens

View raw message