couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Andrews <ch...@nodnol.org>
Subject Re: replication error
Date Fri, 13 Feb 2009 11:04:38 GMT
2009/2/12 Евгений Найденышев <enaidenyshev@gmail.com>:
> Replication failed: {{badmatch,{error,eaddrinuse}},
>  [{couch_rep,do_http_request,3},
>  {couch_rep,open_doc,3},
>  {couch_rep,replicate,3},
>  {couch_httpd,handle_replicate_request,2},
>  {couch_httpd,handle_request,2},
>  {mochiweb_http,headers,4},
>  {proc_lib,init_p_do_apply,3}]}
>
> I tried on different dbs and different ports - and each time was error on
> 1980th document. =(
>
> OS: Windows XP (SP2), Firewall is off.

I'm also getting exactly this error trying to use replication on
Solaris, Nevada build 86, with CouchDB 0.8.1. Erlang version is

"Erlang (BEAM) emulator version 5.6.5 [source] [async-threads:0]
[hipe] [kernel-poll:false]"

Replication works fine with the same version of CouchDB on Linux. I've
investigated as far as to note that each document replicated involves
a new tcp connection to the remote, that Erlang calls bind() before
calling connect(), and that eventually a bind fails, causing the error
above.

I'll see if the same error happens with CouchDB trunk, though.


Chris.

Mime
View raw message