couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul Davis" <paul.joseph.da...@gmail.com>
Subject Re: external 404
Date Mon, 12 Jan 2009 17:21:11 GMT
On Mon, Jan 12, 2009 at 9:31 AM, Jeff Hinrichs - DM&T
<jeffh@dundeemt.com> wrote:
> attempting to replicated http://wiki.apache.org/couchdb/ExternalProcesses
> However, I am getting 404's
>
> Futon on Apache CouchDB  0.9.0a733593-incubating
>
> --local.ini--
> [external]
> test = /home/jlh/Projects/venvs/couch1/test_external.py
>

Try also adding something like:

[httpd_db_handlers]
_test = {couch_httpd_external, handle_external_req, <<"test">>}

And then hit the url:

http://127.0.0.1:5984/delasco-test/_test/

Notice that _test is what the url becomes, and <<"test">> matches the
name you specified in the [external] section.

At least, I'm pretty sure that's the idea. I haven't had the chance to
test this since it got changed.

HTH,
Paul Davis


> tested that test_external.py is runnable by user couchdb, sudo -u
> couchdb /home/jlh/Projects/venvs/couch1/test_external.py
>
> restarted couchdb
>
> Attempts to access http://localhost:5984/delasco-tests/_external/test
> result with {"error":"not_found","reason":"missing"}
>
> logs say:
> [Mon, 12 Jan 2009 14:26:24 GMT] [debug] [<0.63.0>] 'GET'
> /delasco-tests/_external/test {1,1}
> Headers: [{'Accept',"text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8"},
>          {'Accept-Charset',"ISO-8859-1,utf-8;q=0.7,*;q=0.7"},
>          {'Accept-Encoding',"gzip,deflate"},
>          {'Accept-Language',"en-us,en;q=0.5"},
>          {'Connection',"keep-alive"},
>          {'Host',"localhost:5984"},
>          {'Keep-Alive',"300"},
>          {'User-Agent',"Mozilla/5.0 (X11; U; Linux i686; en-US;
> rv:1.9.0.5) Gecko/2008121621 Ubuntu/8.04 (hardy) Firefox/3.0.5"}]
>
> [Mon, 12 Jan 2009 14:26:24 GMT] [debug] [<0.63.0>] HTTPd 404 error response:
>  {"error":"not_found","reason":"missing"}
>
> [Mon, 12 Jan 2009 14:26:24 GMT] [info] [<0.63.0>] 127.0.0.1 - - 'GET'
> /delasco-tests/_external/test 404
>
>
> Appears to be a configuration problem, but I can't seem to figure out what.
>
>
> Regards,
>
> Jeff
> --
>

Mime
View raw message