couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Candler <B.Cand...@pobox.com>
Subject Re: trouble installing on Red Hat 4.1.1
Date Wed, 28 Jan 2009 18:55:09 GMT
On Wed, Jan 28, 2009 at 10:25:44AM -0800, Jay donnell wrote:
> I followed the instructions from the wiki
> http://wiki.apache.org/couchdb/Installing_SpiderMonkey?action=show&redirect=InstallingSpiderMonkey
> and
> http://wiki.apache.org/couchdb/Installing_on_RHEL4
> 
> Whenever I run 'couchdb' I get the error below. I tried the options to
> ./configure and the LD_LIBRARY_PATH but both resulted in the same
> error. Anyone have any ideas?
> 
> Apache CouchDB 0.8.1-incubating (LogLevel=info)
> Apache CouchDB is starting.
> 
> {"init terminating in do_boot","libjs.so: cannot open shared object
> file: No such file or directory"}
> 
> Crash dump was written to: erl_crash.dump
> init terminating in do_boot (libjs.so: cannot open shared object file:
> No such file or directory)
> 
> NOTE: the spidermonkey .so is there
> # ls /usr/local/spidermonkey/lib/
> libjs.a  libjs.so

I have to presume you did --with-js-lib=/usr/local/spidermonkey/lib not
--with-js-lib=/usr/local/spidermonkey/lib64 as it has on the wiki :-)

Try this:

# echo "/usr/local/spidermonkey/lib" >/etc/ld.so.conf.d/spidermonkey.conf
# ldconfig

If that doesn't work, then I can only suggest copying libjs.so into
/usr/local/lib

I have couch running under CentOS 5.2 (= RHEL 5.2), but I just used a
js-1.60 RPM on rpmforge which seems OK.

BTW Red Hat 4.1 is so ancient that there are no more security fixes for it,
so there are good reasons to upgrade to a later 4.x
http://www.redhat.com/support/errata/archives/rh41-errata-general.html

HTH,

Brian.

Mime
View raw message