couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Balint Erdi <balint.e...@gmail.com>
Subject Re: difficulties building couchdb
Date Fri, 19 Dec 2008 16:25:53 GMT
I am not sure. Spidermonkey was installed -apparently- correctly when  
I built couchdb. Does the error make you think it has something to do  
with spidermonkey?

Balint

On Dec 19, 2008, at 4:18 PM, Jan Lehnardt wrote:

> So this is rather "difficulties building Spidermonkey"? :)
>
> Cheers
> Jan
> --
>
> On 19 Dec 2008, at 15:49, Balint Erdi wrote:
>
>> Hey all,
>>
>> I would like to share how I could not make couchdb work when trying  
>> to build everything from source. I try to keep it short but not  
>> omit anything relevant at the  same time.
>>
>> So I downloaded erlang (R12B5) and icu (4c4.0) and made the  
>> configure/make/make install cycle for them. I tried the same with  
>> spidermonkey but after a couple of hours of futile attempts I gave  
>> up and installed the macports version.
>>
>> Then came couchdb. I downloaded 0.8.1-incubating and the build went  
>> fine with no errors. However, that's what I got when I launched  
>> couchdb:
>>
>> $ couchdb
>> {"init terminating in do_boot","dlopen(/usr/local/lib/couchdb/ 
>> erlang/lib/couch-0.8.1-incubating/priv/lib/couch_erl_driver.so, 2):  
>> no suitable image found.  Did find:\n        /usr/local/lib/couchdb/ 
>> erlang/lib/couch-0.8.1-incubating/priv/lib/couch_erl_driver.so:  
>> mach-o, but wrong architecture"}
>>
>> Getting a lot of help on the irc channel I have installed the  
>> latest macports version of automake and autoconf since the above  
>> seemed like the configure script guessed my architecture wrongly.  
>> After that I reinstalled couchdb but received the same error.
>>
>> I checked out the subversion head and compiled from there (after  
>> putting the config.guess and config.sub files into the /build- 
>> contrib directory of the source as suggested) which again went fine  
>> but resulted in the above error.
>>
>> (I also tried to rebuild erlang just to try something but this time  
>> the make process ran into errors so I gave up).
>>
>> Anyway, after all this, I decided to try the macports version of  
>> couchdb which works perfectly so I am a happy couchdb user now but  
>> just wanted to let you know. Maybe it is a bug that can be patched.  
>> Ah, I use OSX 10.5.5.
>>
>> And once more, thank all of you who helped me on the irc,
>> Balint
>>
>>
>>
>>
>>
>


Mime
View raw message