couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shailesh Kochhar <>
Subject Installing couchdb from source on Gentoo64
Date Wed, 26 Nov 2008 19:18:44 GMT
Morning Everyone,

I'm having a spot of difficulty installing couchdb-0.8.1 from sources on
a gentoo system. I used the ebuild here

as a rough guide to getting the dependencies ready.

I installed icu, spidermonkey and svn2cl by emerging the latest
packages. I built the latest erlang from sources and installed in

I then tried to build couchdb by grabbing the source tarball. After
unpacking I immediately noticed that there was no ./bootstrap

I then tried,
./configure --with-erlang=/my/homedir/lib/erlang/erts-5.6.3/include \
             --with-js-include=/usr/include/js \

I get a whole bunch of configure output ending with:

checking for JS_NewContext in -ljs... no
checking for JS_NewContext in -lmozjs... no
configure: error: Could not find the js library.

Is the Mozilla SpiderMonkey library installed?

I think this thread <> is
pertinent. However, after applying the patch mentioned there, I still 
get the same error.

I poked around in config.log a little and found this snippet which might 
be useful.

configure:19936: checking for JS_NewContext in -ljs
configure:19971: gcc -o conftest -g -O2 -L/usr/local/lib 
-L/opt/local/lib  -I${exec_prefix}/lib/erlang/usr/include 
-I/usr/lib/erlang/usr/include -I/usr/local/lib/erlang/usr/include 
-I/opt/local/lib/erlang/usr/include -I/usr/include/js 
-I/usr/include/mozjs -I/usr/local/include/js -I/opt/local/include/js 
-DXP_UNIX   -L/usr/local/lib -L/opt/local/lib 
-I${exec_prefix}/lib/erlang/usr/include -I/usr/lib/erlang/usr/include 
-I/usr/local/lib/erlang/usr/include -I/opt/local/lib/erlang/usr/include 
-I/usr/include/js -I/usr/include/mozjs -I/usr/local/include/js 
-I/opt/local/include/js -DXP_UNIX   conftest.c -ljs  -L/usr/local/lib 
-L/opt/local/lib  -lpthread  >&5
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.1/../../../../lib64/ file 
not recognized: File format not recognized

If someone could point me to the next steps I should take, it would be 
much appreciated. I have a sneaky suspicion that I might have grabbed 
the wrong version of the sources. I'll go look.

Thanks for your attention.

   - Shailesh

View raw message