couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Lehnardt <...@apache.org>
Subject Re: Cannot access _utils
Date Mon, 24 Nov 2008 16:25:30 GMT
Can you paste the trace that happens with trunk? And can you try  
building Erlang by hand?

I've never seen this error.

Cheers
Jan
--

On 22.11.2008, at 07:50, "Kridsada Thanabulpong" <naises@gmail.com>  
wrote:

> Hello,
>
> I'm trying to play around with CouchDB, but I can't access the web
> management interface for some reason, although I can access the HTTP
> API, creating new database, adding new documents, visit _replicate,
> just not being able to access the web management interface. I've
> installed everything from MacPorts and is using Erlang R12B-5. I've
> also tried building from trunk, but the problem still remains.
>
> Here's the errors:
>
>> % erl
>> Erlang (BEAM) emulator version 5.6.5 [source] [async-threads:0]  
>> [kernel-poll:false]
>>
>> % sudo -u couchdb couchdb
>> Apache CouchDB 0.8.1-incubating (LogLevel=debug)
>> Apache CouchDB is starting.
>>
>> Apache CouchDB has started. Time to relax.
>> [debug] [<0.1.0>] Config Info /opt/local/etc/couchdb/couch.ini:
>>        CurrentWorkingDir=/Users/sirn
>>        DbRootDir=/opt/local/var/lib/couchdb
>>        BindAddress="127.0.0.1"
>>        Port="5984"
>>        DocumentRoot=/opt/local/share/couchdb/www
>>        LogFile=/opt/local/var/log/couchdb/couch.log
>>        UtilDriverDir=/opt/local/lib/couchdb/erlang/lib/couch-0.8.1- 
>> incubating/priv/lib
>>        DbUpdateNotificationProcesses=
>>        FullTextSearchQueryServer=
>>        javascript=/opt/local/bin/couchjs /opt/local/share/couchdb/ 
>> server/main.js
>>
>> [debug] [<0.52.0>] GET /_utils/ {1,1}
>> Headers: [{'Accept',"text/html, application/xml;q=0.9, application/ 
>> xhtml+xml, image/png, image/jpeg, image/gif, image/x-xbitmap, */ 
>> *;q=0.1"},
>>          {'Accept-Charset',"iso-8859-1, utf-8, utf-16, *;q=0.1"},
>>          {'Accept-Encoding',"deflate, gzip, x-gzip, identity,  
>> *;q=0"},
>>          {'Accept-Language',"en,ja;q=0.9,th;q=0.8,ko;q=0.7"},
>>          {'Cache-Control',"no-cache"},
>>          {'Connection',"Keep-Alive, TE"},
>>          {'Host',"127.0.0.1:5984"},
>>          {"Te","deflate, gzip, chunked, identity, trailers"},
>>          {'User-Agent',"Opera/9.62 (Macintosh; PPC Mac OS X; U; en)  
>> Presto/2.1.1"}]
>> [info] [<0.52.0>] HTTP Error (code 500): {'EXIT',
>>                           {badarg,
>>                               [{erlang,universaltime_to_localtime,
>>                                    [{{1969,12,31},{23,59,59}}]},
>>                                 
>> {calendar,local_time_to_universal_time_dst,1},
>>                                {httpd_util,rfc1123_date,1},
>>                                {mochiweb_request,serve_file,4},
>>                                {couch_httpd,handle_request0,4},
>>                                {couch_httpd,handle_request,2},
>>                                {mochiweb_http,headers,4},
>>                                {proc_lib,init_p_do_apply,3}]}}
>> [info] [<0.52.0>] 127.0.0.1 - - "GET /_utils/" 500
>
> I've also tried visiting /_utils using Safari, Firefox and curl but
> the problem still remains. The error report from development build is
> similar. Is there any way to fix this?
>
> Thanks
>

Mime
View raw message