couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Noah Slater <nsla...@apache.org>
Subject Re: Installing couchdb from source on Gentoo64
Date Wed, 26 Nov 2008 20:11:48 GMT
On Wed, Nov 26, 2008 at 11:18:44AM -0800, Shailesh Kochhar wrote:
> I then tried to build couchdb by grabbing the source tarball. After
> unpacking I immediately noticed that there was no ./bootstrap

You only need the bootstrap if you're installing from Subversion.

> I then tried,
> ./configure --with-erlang=/my/homedir/lib/erlang/erts-5.6.3/include \
>             --with-js-include=/usr/include/js \
>             --with-js-lib=/usr/lib64
...
> checking for JS_NewContext in -ljs... no
> checking for JS_NewContext in -lmozjs... no
> configure: error: Could not find the js library.

All this means is that the SpiderMonkey library is not being found by the
configure script using the paths supplied.

Can you tell us the exact locations of the SpiderMonkey files on your system?

Thanks,

-- 
Noah Slater, http://tumbolia.org/nslater

Mime
View raw message