couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Anderson" <jch...@apache.org>
Subject Re: database connectivity for sproutcore installation problems
Date Tue, 28 Oct 2008 16:40:47 GMT
Looks like you need to install git before that will work.

Also it looks like that won't contain couchdb, just the sproutcore
adapter. See http://incubator.apache.org/couchdb/community/code.html
for the CouchDB source code.

On Tue, Oct 28, 2008 at 9:26 AM, Srilatha Bhuvanapalli
<latha@ninjasolutions.com> wrote:
> Hi,
>
> I have been trying to use CouchDB with sproutcore. I have a Mac Leopard and
> am trying
> to install CouchDB using the below command. I have been getting an
> error. Could I please know how to resolve this issue.
>
> Dir I am trying to install from:
> srilatha-bhuvanapallis-macbook-pro:bin Latha$ pwd
> /Library/Ruby/Gems/1.8/gems/sproutcore-0.9.19/bin
>
> Command with error below that:
>
> rilatha-bhuvanapallis-macbook-pro:bin Latha$ sc-install geoffreyd-
> couchdb
> sc-install v0.9.19
> Installing geoffreyd-couchdb...
>  ~ Fetching from git://
> github.com/geoffreyd/sproutcore-couchdb/Library/Ruby/Gems/1.8/gems/sp
>  routcore-0.9.19/lib/sproutcore/
> library.rb:378: command not found: git --version
> /Library/Ruby/Gems/1.8/gems/sproutcore-0.9.19/lib/sproutcore/
> bundle_installer.rb:180:in `fetch': ZIP not yet supported!
> (RuntimeError)
>        from /Library/Ruby/Gems/1.8/gems/sproutcore-0.9.19/lib/sproutcore/
> bundle_installer.rb:95:in `install'
>        from /Library/Ruby/Gems/1.8/gems/sproutcore-0.9.19/lib/sproutcore/
> library.rb:336:in `install_bundle'
>        from
> /Library/Ruby/Gems/1.8/gems/sproutcore-0.9.19/bin/sc-install:97
>        from /usr/bin/sc-install:19:in `load'
>        from /usr/bin/sc-install:19
> Could someone please let me know how to resolve this issue. I have
> been stuck on this for a couple of days now.
>
> Thanks
> Latha
>



-- 
Chris Anderson
http://jchris.mfdz.com

Mime
View raw message