couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Evans" <>
Subject Re: Erlang crash on new install of couchdb
Date Mon, 21 Jul 2008 23:53:40 GMT
I found the Erlang crash dump viewer web tool and it doesn't even really
look like it's getting to the point where couchdb is getting loaded.  I ran
another Erlang app that I have just to make sure that the emulator is
working in general and it worked just fine.  For lack of any better ideas,
I'll start exploring the bin/couchdb script and see what I can find, but is
there anything special going on with the way the emulator is invoked for
couchdb that might explain why it's bombing before it even gets to couchdb


On Mon, Jul 21, 2008 at 4:33 PM, John Evans <> wrote:

> Hi All,
> I had a nice happy version of couchdb running from the trunk for the past
> couple of weeks when we encountered a drive failure at our hosting provider
> which required a clean install of the machine.  I was able to restore the
> entire couchdb directory unharmed, but the OS was a clean install (of Ubuntu
> Hardy), so I had to go through and install all of the dependencies like
> Erlang.  Well, after getting everything (I think?) i place, I was getting
> this failure:
> $ bin/couchdb
> {"init terminating in
> do_boot",{undef,[{crypto,start,[]},{erl_eval,do_apply,5},{init,start_it,1},{init,start_em,1}]}}
> Crash dump was written to: erl_crash.dump
> init terminating in do_boot ()
> I then remembered that based on one of the previous issues I asked about on
> the mailing list I had previously installed the most recent version of
> Erlang instead of using the one installed by Ubuntu's apt-get, so I thought
> that may help here and built and installed R12B3 from source.
> This didn't help, so I thought there must be some other problem with the
> couchdb installation itself, so I blew it away and did a clean build/install
> from the same checkout of the trunk that I used before but I am still
> getting the same error.
> The erl_crash.dump is here:
> Any ideas?  Are there tools for interpreting the crash dump?
> -
> John

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message