couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sho Fukamachi <sho.fukama...@gmail.com>
Subject Re: errors in tests
Date Sat, 03 May 2008 06:05:21 GMT
Sorry to double post, but I just did an svn up and now it's a  
different error message from couchjs - and a crash when you try to run  
couchdb.

configure line:

./configure --with-js-lib=/usr/local/spidermonkey/lib64 --with-js- 
include=/usr/local/spidermonkey/include

testing couchjs:

# /usr/local/bin/couchjs /usr/local/share/couchdb/server/main.js
/usr/local/lib/couchdb/bin/couchjs: error while loading shared  
libraries: libjs.so: cannot open shared object file: No such file or  
directory

libjs.so?

# locate libjs.so
/root/src/js/src/Linux_All_DBG.OBJ/libjs.so
/usr/local/spidermonkey/lib64/libjs.so

Now it can't find it! Well, it's an improvement : )

# ls -la /usr/local/spidermonkey/lib64/
total 2072
drwxr-xr-x  2 root root    4096 May  1 07:04 .
drwxr-xr-x  5 root root    4096 May  1 07:02 ..
-rw-r--r--  1 root root 1219254 May  2 05:55 libjs.a
-rwxr-xr-x  1 root root  883089 May  2 05:55 libjs.so

Everything's being done as root so i don't think it's a permissions  
problem.

Running couchdb now crashes with a crashlog. I've zipped it and placed  
it at http://fukamachi.org/media/erl_crash.dump.gz if you're  
interested...

thanks again,

Sho



On 03/05/2008, at 7:47 AM, Christopher Lenz wrote:

> On 01.05.2008, at 23:32, Sho Fukamachi wrote:
>> I followed the steps in the troubleshooting page you linked to.  
>> I've copied my entire step-by-step process below, exactly as I did  
>> it. Bear in mind though that js/spidermonkey is not included in  
>> that - the logs suggest the error is in couchjs, but could that be  
>> affected by a bad spidermonkey install?
>
> Absolutely, but also by a bad Erlang install.
>
> I've had a very similar problem with Erlang on Debian Etch on an  
> AMD64 Linode. I was using the Erlang version available via apt-get,  
> and seeing problems like those you're seeing. I then tried to  
> install Erlang from source, only to see the configure script hang on  
> a line "checking floating point exceptions" (or similar). After some  
> research it turns out this was a compatibility problem with AMD64,  
> but you could disable HiPE to get around it. Which is what I did (./ 
> configure --disable-hipe IIRC), and things worked.
>
> (I've since got upgraded to a different Xen-based virtual machine  
> where the system Erlang works fine.)
>
> One symptom of this is if couchjs works as expected when run  
> manually from the command-line, e.g.
>
>  $ /usr/local/couchdb/bin/couchjs /usr/local/couchdb/share/couchdb/ 
> server/main.js
>  ["reset"]
>  true
>
> (First line is the commandline invocation, second line is what you  
> type in when couchjs waits for input, and third line is the expected  
> output).
>
> If this works, then please have a closer look at rebuilding erlang  
> with HiPE disabled.
>
> If it doesn't work, there's probably something wrong with your  
> spidermonkey installation.
>
> Cheers,
> Chris
> --
> Christopher Lenz
>  cmlenz at gmx.de
>  http://www.cmlenz.net/
>


Mime
View raw message