couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Lenz <cml...@gmx.de>
Subject Re: errors in tests
Date Fri, 02 May 2008 21:47:24 GMT
On 01.05.2008, at 23:32, Sho Fukamachi wrote:
> I followed the steps in the troubleshooting page you linked to. I've  
> copied my entire step-by-step process below, exactly as I did it.  
> Bear in mind though that js/spidermonkey is not included in that -  
> the logs suggest the error is in couchjs, but could that be affected  
> by a bad spidermonkey install?

Absolutely, but also by a bad Erlang install.

I've had a very similar problem with Erlang on Debian Etch on an AMD64  
Linode. I was using the Erlang version available via apt-get, and  
seeing problems like those you're seeing. I then tried to install  
Erlang from source, only to see the configure script hang on a line  
"checking floating point exceptions" (or similar). After some research  
it turns out this was a compatibility problem with AMD64, but you  
could disable HiPE to get around it. Which is what I did (./configure  
--disable-hipe IIRC), and things worked.

(I've since got upgraded to a different Xen-based virtual machine  
where the system Erlang works fine.)

One symptom of this is if couchjs works as expected when run manually  
from the command-line, e.g.

   $ /usr/local/couchdb/bin/couchjs /usr/local/couchdb/share/couchdb/ 
server/main.js
   ["reset"]
   true

(First line is the commandline invocation, second line is what you  
type in when couchjs waits for input, and third line is the expected  
output).

If this works, then please have a closer look at rebuilding erlang  
with HiPE disabled.

If it doesn't work, there's probably something wrong with your  
spidermonkey installation.

Cheers,
Chris
--
Christopher Lenz
   cmlenz at gmx.de
   http://www.cmlenz.net/


Mime
View raw message