couchdb-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Bell <a...@theopenlearningcentre.com>
Subject Re: can't find SpiderMonkey
Date Sat, 08 Mar 2008 22:35:21 GMT
well I update the wiki with installation instructions. When couchdb gets 
packaged as an RPM and .deb obviously the dependency information would 
need to be in the package so that apt or yum can just sort out the 
problems and fetch what it needs (presumably it would not need the devel 
packages when compiled)

It would be great for the configure script to suggest package names like 
js, js-devel and icu, libicu-devel when it trips up over SpiderMonkey 
and ICU etc.
Maybe the readme could be updated with the dependency information for 
Redhat based systems.
It wouldn't hurt to have a little shell script which installs all the 
dependencies via yum or apt-get as appropriate.

Alan.

Noah Slater wrote:
> On Sat, Mar 08, 2008 at 10:14:55PM +0000, Alan Bell wrote:
>   
>> and now I have Apache CouchDB 0.7.3a763 running on the OLPC XO laptop!
>>     
>
> Fantastic! Looking back, is there any way you think the error messages could be
> improved, I would like to fix this for future users too.
>
> Thanks,
>
> --
> Noah Slater <http://bytesexual.org/>
>   


-- 
Alan Bell
The Open Learning Centre

Web: www.theopenlearningcentre.com
Mob: +44 (0)7736 778908
Tel: +44 (0)8444 849388

The Open Learning Centre is a trading name of Bell Lord Ltd,
a company registered in England and Wales #05868943.
VAT Registration #GB 901 4715 55



Mime
View raw message