couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joey Samonte <csharpdevelo...@hotmail.com>
Subject RE: Error updating database permissions
Date Thu, 08 Sep 2016 17:50:02 GMT
I am not using the dev/run setup, but the multi-server install.
What I noticed is that the "all_nodes" and "cluster_nodes" have couchdb@localhost by default.
Adding a node does not update the "all_nodes". It always just contains that one entry.
 
> Subject: Re: Error updating database permissions
> From: rnewson@apache.org
> Date: Thu, 8 Sep 2016 11:04:45 +0100
> To: dev@couchdb.apache.org
> 
> maybe you're mixing a dev/run setup with a proper (multi server) install? Hard to tell
from this.
> 
> You should _either_ have entries like these (for dev/run);
> 
> node1@127.0.0.1
> node2@127.0.0.1
> node3@127.0.0.1
> 
> or entries like these (for a production cluster)
> 
> couchdb@db1.somedomain.com
> couchdb@db2.somedomain.com
> couchdb@db3.somedomain.com
> 
> (or externally-resolvable ip addresses) 
> 
> 
> Look at the vm.args file for each node, that's where the -name is set.
> 
> 
> > On 7 Sep 2016, at 21:40, Joey Samonte <csharpdeveloper@hotmail.com> wrote:
> > 
> > I didn't add @localhost. It is there by default. Also, the "all_nodes" is not updated.
> > 
> >> Subject: Re: Error updating database permissions
> >> From: rnewson@apache.org
> >> Date: Wed, 7 Sep 2016 20:59:16 +0100
> >> To: dev@couchdb.apache.org
> >> 
> >> @localhost isn't going to work, each node will need to be referenced by a name
that actually resolves to the node, so either want to use a domain name or the external ip
address.
> >> 
> >> 
> >>> On 7 Sep 2016, at 11:51, Joey Samonte <csharpdeveloper@hotmail.com>
wrote:
> >>> 
> >>> I have followed the steps here:
> >>> http://docs.couchdb.org/en/latest/cluster/index.html
> >>> 
> >>> Or here:
> >>> https://docs.google.com/document/d/1BtndYr-0KDQTqBSLVdJoR_8C5ObYjT1RBo_Qyh5ykdQ/edit
> >>> 
> >>> But the nodes are not being added correctly. Are there any updated documentation
on setting up a cluster?
> >>> 
> >>> I have added a node 2 to a cluster. From node 1, looking at _membership
shows this:
> >>> 
> >>> {"all_nodes":["couchdb@localhost"],"cluster_nodes":["couchdb@xx.xx.xx.xx","couchdb@localhost"]}
> >>> 
> >>> But looking at _membership at node 2, it shows differently:
> >>> 
> >>> {"all_nodes":["couchdb@localhost"],"cluster_nodes":["couchdb@localhost"]}
> >>> 
> >>> 
> >>>> Subject: Re: Error updating database permissions
> >>>> From: rnewson@apache.org
> >>>> Date: Wed, 7 Sep 2016 10:48:01 +0100
> >>>> To: dev@couchdb.apache.org
> >>>> 
> >>>> check host:5984/_membership on each node of your cluster, perhaps you
don't have a fully-connected cluster right now. All nodes should be listed under both "all_nodes"
and "cluster_nodes" by every node in your cluster.
> >>>> 
> >>>> B.
> >>>> 
> >>>> 
> >>>>> On 7 Sep 2016, at 08:35, Joey Samonte <csharpdeveloper@hotmail.com>
wrote:
> >>>>> 
> >>>>> Good day,
> >>>>> 
> >>>>> Whenever I try to update the database permissions using Fauxton,
I am getting an error with a reason: no_majority.
> >>>>> What could be the reason for this?
> >>>>> 
> >>>>> Thanks. 
> >>>>> 		 	   		  
> >>>> 
> >>> 		 	   		  
> >> 
> > 		 	   		  
> 
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message