couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Garren Smith <gar...@apache.org>
Subject Re: npm fauxton
Date Sun, 01 May 2016 16:32:18 GMT
Ok that is helpful. Could you check package.json and make sure we have
those dependencies in the right place. Also in the Fauxton directory you
can do npm install . -g to test a package before installing[1].

If you get stuck I can take a look tomorrow or Tuesday

[1] https://docs.npmjs.com/misc/developers

On Sunday, 01 May 2016, Michelle Phung <michellephung@gmail.com> wrote:

> Hey Garren,
>
> I didn’t get anything errors when i did npm install -g fauxton, but I got
> an error in the browser: couldn’t find module ‘react-select’
>
> I got these errors when i did 'npm publish’:
>
> ERROR in
> ./app/addons/documents/index-results/index-results.components.react.jsx
> Module not found: Error: Cannot resolve module
> 'react-select/dist/react-select.css' in
> /Users/michellephung/Apache/couchdb-fauxton/app/addons/documents/index-results
>  @ ./app/addons/documents/index-results/index-results.components.react.jsx
> 17:0-562:2
>
> ERROR in
> ./app/addons/documents/index-results/index-results.components.react.jsx
> Module not found: Error: Cannot resolve module 'react-select' in
> /Users/michellephung/Apache/couchdb-fauxton/app/addons/documents/index-results
>  @ ./app/addons/documents/index-results/index-results.components.react.jsx
> 17:0-562:2
>
> ERROR in
> ./app/addons/documents/rev-browser/rev-browser.components.react.jsx
> Module not found: Error: Cannot resolve module 'react-select' in
> /Users/michellephung/Apache/couchdb-fauxton/app/addons/documents/rev-browser
>  @ ./app/addons/documents/rev-browser/rev-browser.components.react.jsx
> 23:0-592:2
>
> ERROR in
> ./app/addons/documents/rev-browser/rev-browser.components.react.jsx
> Module not found: Error: Cannot resolve module
> 'react-select/less/default.less' in
> /Users/michellephung/Apache/couchdb-fauxton/app/addons/documents/rev-browser
>  @ ./app/addons/documents/rev-browser/rev-browser.components.react.jsx
> 23:0-592:2
>
> ERROR in
> ./app/addons/documents/rev-browser/rev-browser.components.react.jsx
> Module not found: Error: Cannot resolve module
> 'jsondiffpatch/src/formatters/html' in
> /Users/michellephung/Apache/couchdb-fauxton/app/addons/documents/rev-browser
>  @ ./app/addons/documents/rev-browser/rev-browser.components.react.jsx
> 23:0-592:2
>
> ERROR in
> ./app/addons/documents/rev-browser/rev-browser.components.react.jsx
> Module not found: Error: Cannot resolve module
> 'jsondiffpatch/public/formatters-styles/html.css' in
> /Users/michellephung/Apache/couchdb-fauxton/app/addons/documents/rev-browser
>  @ ./app/addons/documents/rev-browser/rev-browser.components.react.jsx
> 23:0-592:2
>
> ERROR in
> ./app/addons/documents/rev-browser/rev-browser.components.react.jsx
> Module not found: Error: Cannot resolve module 'jsondiffpatch' in
> /Users/michellephung/Apache/couchdb-fauxton/app/addons/documents/rev-browser
>  @ ./app/addons/documents/rev-browser/rev-browser.components.react.jsx
> 23:0-592:2
>
> ERROR in ./app/addons/documents/rev-browser/rev-browser.actions.js
> Module not found: Error: Cannot resolve module
> 'visualizeRevTree/lib/getTree' in
> /Users/michellephung/Apache/couchdb-fauxton/app/addons/documents/rev-browser
>  @ ./app/addons/documents/rev-browser/rev-browser.actions.js 17:0-157:2
>
> ERROR in ./app/addons/documents/rev-browser/rev-browser.actions.js
> Module not found: Error: Cannot resolve module 'pouchdb' in
> /Users/michellephung/Apache/couchdb-fauxton/app/addons/documents/rev-browser
>  @ ./app/addons/documents/rev-browser/rev-browser.actions.js 17:0-157:2
>
>
> and  then:
>
>
> ERROR in ../~/react-select/lib/Select.js
> Module not found: Error: Cannot resolve module 'react' in
> /Users/michellephung/Apache/node_modules/react-select/lib
>  @ ../~/react-select/lib/Select.js 11:13-29
>
> ERROR in ../~/react-select/lib/Select.js
> Module not found: Error: Cannot resolve module 'react-dom' in
> /Users/michellephung/Apache/node_modules/react-select/lib
>  @ ../~/react-select/lib/Select.js 15:16-36
>
> ERROR in ../~/react-input-autosize/lib/AutosizeInput.js
> Module not found: Error: Cannot resolve module 'react' in
> /Users/michellephung/Apache/node_modules/react-input-autosize/lib
>  @ ../~/react-input-autosize/lib/AutosizeInput.js 5:12-28
>
> ERROR in ../~/react-select/lib/Async.js
> Module not found: Error: Cannot resolve module 'react' in
> /Users/michellephung/Apache/node_modules/react-select/lib
>  @ ../~/react-select/lib/Async.js 7:13-29
>
> ERROR in ../~/react-select/lib/Option.js
> Module not found: Error: Cannot resolve module 'react' in
> /Users/michellephung/Apache/node_modules/react-select/lib
>  @ ../~/react-select/lib/Option.js 5:13-29
>
> ERROR in ../~/react-select/lib/Value.js
> Module not found: Error: Cannot resolve module 'react' in
> /Users/michellephung/Apache/node_modules/react-select/lib
>  @ ../~/react-select/lib/Value.js 5:13-29
>
>
> but by then it was too late! it was already published.
> I didn’t want to leave our package broken on npm, so i set our latest
> version back to 1.1.2
> everything working correctly if you git clone from master and run npm run
> dev though.
>
> -michelle
>
> On May 1, 2016, at 11:31 AM, Garren Smith <garren@apache.org
> <javascript:_e(%7B%7D,'cvml','garren@apache.org');>> wrote:
>
> Hi Michelle,
>
> That's weird. Any installation errors when you did npm install -g fauxton?
> Also any errors that you could see?
>
> Cheers
> Garren
>
> On Sunday, 01 May 2016, Michelle Phung <michellephung@gmail.com
> <javascript:_e(%7B%7D,'cvml','michellephung@gmail.com');>> wrote:
>
> hello,
>
> I was updating the npm fauxton release today, and published the tag 1.1.3.
>
> Usually my next step would be to update the rebar.config file couchdb, but
> when I tested the new release (reinstalling it globally), then fauxton,
> then localhost:8000, it wasn’t working, so i reset 1.1.2 as the latest
> release. (so that if anyone npm installs it today, it will work.)
>
> Everything is working right now, but if it needs to be updated, there’ll
> be issues.
>
> -michelle
> Gobstopper
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message