couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maria Andersson <ma...@dualpose.com>
Subject A move for docs and status of the alpha
Date Tue, 26 Jan 2016 14:23:06 GMT
(Spoiler: We have no documentation and make install is broken)

I want to start developing against 2.0 but there is no documentation.
So when I want to try out a new feature, I have to ask questions on
IRC. Nothing wrong with that, but it is a bit slow and not everyone
trying out 2.0 will take the time needed to ask. And it might be
annoying if a lot of people ask the same questions all the time.

To fix this I have created https://github.com/mar-ia/couchdb-info-dump
to collect everything that is new in 2.0. As the name implies, this is
a dump. No need to worry about grammar and formatting, just throw it in.
Or throw it at me if you prefer. Send it to this thread, do a pull
request or ping me at IRC. Anyway you want. Pointing to the source code
(bulk_get is new see some_file.erl:35-124 for options) is ok too.
So very informal :)

When everything is in there, then if someone feels like writing
documentation, they know where to look and what questions to ask :)

I have also updated https://github.com/mar-ia/couchdb-crazy to work
with the current master. This is still the only way that I have manged
to start 2.0. (./dev/run does not count) The result of "make install"
is told bellow in "Trying out the alpha".

A little list of bugs:
Fauxton:
    Url of documents in a view in table view misses _utils/#/
        (http://ip:port/<it should be here>database/database-name/doc-id)
    Lists all shards on the backport with the error message
        "This database failed to load."
make:
    The docs are not built. (The html version was actually built once.)
    Git artifacts in the tarball.
    The inifiles are installed in 2 places. (lib/couchdb/etc and etc/couchdb)
bin/couchdb:
    Can not start if couchdb is installed into a custom directory.
        (./configure --prefix="/path/to/dir")
compaction:
    Crashes on a corrupt document in a shard instead of fetching a
        healthy copy from the cluster and heal the shard.

Anyway, I have a 3 node cluster running 2.0 that replicates real data
from a 1.6.1. So I am using it daily now \o/

// Maria

*** Trying out the alpha ***
I tried to install and configure a single node following the guide
https://docs.google.com/document/d/1BtndYr-0KDQTqBSLVdJoR_8C5ObYjT1RBo_Qyh5ykdQ
using apache-couchdb-2.0.0-a18004d.tar.gz (2016-01-12T16:01:33.000Z)
from http://couchdb.apache.org/release-candidate/2.0/
I ran it on on my laptop with Gentoo 64bit.

make fails with:
Compiling /home/user/couchdb/apache-couchdb-2.0.0-a18004d/src/couch/priv/couch_js/http.c
In file included
from /home/user/couchdb/apache-couchdb-2.0.0-a18004d/src/couch/priv/couch_js/http.c:19:0:
priv/couch_js/config.h:8:24: warning: missing terminating " character
#define PACKAGE_STRING "Apache CouchDB fatal: Not a git repository (or any parent up to mount
point /home)

So I did a git clone and used master instead :)

The docs are not built so they can not be installed. They had to be
disabled. I tried to install in a directory in my home dir,
with ./configure --prefix="/path/to/dir" but couchdb looks for the
configfiles in the default places, so I could not get it to start.

So I did a system install instead :D
(I have snapshots so easy to restore.)

If I run "make install" as root then the permissions are wrong so to
get around that I did it as a user. But first I had to create the
following file and directories and chown them to my user account.

touch /usr/local/bin/couchdb
mkdir /usr/local/lib/couchdb
mkdir -p /usr/local/libexec/couchdb
mkdir -p /usr/local/etc/couchdb
mkdir -p /usr/local/share/couchdb
mkdir -p /usr/local/share/doc/apache-couchdb

Finally installed and starts by running "couchdb" in a terminal \o/
But nothing works /o\
After some time of frustration I found the problem. The
inifiles(default.ini and local.ini) are in 2 places and I changed the
wrong ones. The ones that are used are in /usr/local/lib/couchdb/etc/
and I edited the ones in /usr/local/etc/couchdb/

At this point I gave up :$
Almost got it to work though.

***

Mime
View raw message