couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Shorin <kxe...@gmail.com>
Subject Re: Erlang release number mismatch
Date Tue, 21 Jul 2015 04:39:01 GMT
Hi Florin,

In general, it will work, but may cause some specific problems later.
See https://gist.github.com/chewbranca/07d9a6eed3da7b490b47 for more
info.
--
,,,^..^,,,


On Tue, Jul 21, 2015 at 1:15 AM, Florin Andrei <florin@andrei.myip.org> wrote:
> Trying to build the developer release on Ubuntu 14.04, following the
> instructions here:
>
> http://couchdb.apache.org/developer-preview/2.0/
>
> I'm using the packages in the Ubuntu repository for all dependencies, except
> rebar - it's rebar-2.0.0 in Ubuntu 14.04, which is too old (and ./configure
> fails), so I've upgraded it to rebar-2.6.0, then ./configure works fine. So
> far so good.
>
> When running make, I get this:
>
> ==> b64url (compile)
> ERROR: OTP release R16B03 does not match required regex
> R14B01|R14B03|R14B04|R16B02|R16B03-1|17
> ERROR: compile failed while processing /root/couchdb/src/b64url: rebar_abort
> make: *** [couch] Error 1
>
> So I've edited rebar.config.script and added the missing pattern there:
>
>     {require_otp_vsn, "R14B01|R14B03|R14B04|R16B02|R16B03-1|R16B03|17"},
>
> Is that okay, or will it cause problems later on?
>
> --
> Florin Andrei
> http://florin.myip.org/

Mime
View raw message