couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dale Harvey (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-2237) Add a 'live' sugar for 'continuous'
Date Sat, 04 Apr 2015 14:21:54 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-2237?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14395738#comment-14395738
] 

Dale Harvey commented on COUCHDB-2237:
--------------------------------------

I wouldnt suggest any breaking changes, we support both and its mostly a one line change (https://github.com/pouchdb/pouchdb/blob/master/lib/changes.js#L132)


I dont thing stream is a good name since it is easily confused with the efforts to turn replication
into an actual stream. 

However I think Couch could use live, watch or follow easily based on these patches, and if
Couch went for an option that wasnt 'live' we would implement it in PouchDB as well. However
I am not day to day involved enough in CouchDB to be trying to push for a change if people
are against it.

We have had this for a long time in PouchDB, its been very nice to not have to deal with the
hard to spell continuous and it doesnt look like anyone is confused by the term 'live' and
I dont hold much of a preference between live / watch / follow, I think semantically they
are equally clear (or unclear). Its just a nice touch of usability in the API

> Add a 'live' sugar for 'continuous'
> -----------------------------------
>
>                 Key: COUCHDB-2237
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-2237
>             Project: CouchDB
>          Issue Type: Improvement
>      Security Level: public(Regular issues) 
>          Components: HTTP Interface
>            Reporter: Dale Harvey
>
> With PouchDB we generally try to stick to the same param names as Couch, we are even
changing some we implemented first to be compatible (https://github.com/pouchdb/pouchdb/issues/2193)
> However 'continuous' sucks to type, its confusing to type and spell and everyone gets
it wrong, we still support it but switched to documenting it as 'live' and life is awesome
again



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message