couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Shorin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-1577) Refuse start when underlying Erlang version has changed
Date Sun, 16 Nov 2014 20:52:34 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-1577?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14214071#comment-14214071
] 

Alexander Shorin commented on COUCHDB-1577:
-------------------------------------------

[~janl] so this suppose to be fixed for 2.0 right?

> Refuse start when underlying Erlang version has changed
> -------------------------------------------------------
>
>                 Key: COUCHDB-1577
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-1577
>             Project: CouchDB
>          Issue Type: Bug
>    Affects Versions: 1.2
>         Environment: All
>            Reporter: Jan Lehnardt
>
> When a user installs CouchDB from source and then updates the Erlang version on the system,
spurious errors can occur (like COUCHDB-1571). On install, we should detect the Erlang version
and store it with the CouchDB installation, and then bail if things don't match up during
start time. I recon this could be coded entirely in bin/couchdb, no erlang required.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message