couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Shorin <kxe...@gmail.com>
Subject Fauxton compatibility with CouchDB 1.x
Date Sat, 09 Aug 2014 20:58:24 GMT
Hi devs,

There was raised interesting question about Fauxton compatibility with
CouchDB 1.x series. Currently this compatibility is broken in form of
[COUCHDB-2244] issue and [#57923f457] commit. And that's only which we
aware for now.

So what is the general plan? Make Fauxton works fine with 2.0 leaving
1.x support out of border (and certainly, there will no more updates
for experimental feature), or keep it compatible with both for a while
until 1.x will gone into the history? I think we should set all dots
above the i in this question. As a side effect this will explicitly
define required testing environment for Fauxton - personally, I'm
using and reporting issues against 1.x which may be irrelevant for
2.x.

So what's the plan have to be? What do you think?

[COUCHDB-2244]: https://issues.apache.org/jira/browse/COUCHDB-2244
[#57923f457]: https://github.com/apache/couchdb-fauxton/commit/57923f457

--
,,,^..^,,,

Mime
View raw message