couchdb-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dave Cottlehuber (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COUCHDB-2287) couchdb 1.6 crash on FreeBSD 10
Date Wed, 30 Jul 2014 09:29:38 GMT

    [ https://issues.apache.org/jira/browse/COUCHDB-2287?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14079102#comment-14079102
] 

Dave Cottlehuber commented on COUCHDB-2287:
-------------------------------------------

I just checked this on FreeBSD-11.0-CURRENT, all is good here. If you've upgraded couchdb,
did you ensure the erlang port also matches?

 In a default ports install, these /usr/local/* files should obviously be world readable;
something's gone wrong.

    drwxr-xr-x  10 root  wheel    14B 26 Jul 21:11 erlang/

Best is to su/sudo as the couchdb user, then run `couchdb -i` which is the interactive console,
and you can see pretty quickly what's not working. 

You'll only need to fix a few things after trying to run as root;  ensure permissions are
as Joan's mentioned: see http://couchdb.readthedocs.org/en/latest/install/unix.html#security-considerations
the OSX section with chmods  applies equally well to FreeBSD. Especially the .couch files
and their dirs, anything in /var/db/couchdb/ as well.

If the above can't help please email user@couchdb.apache.org and we'll take it from there.
I'm closing this as not a problem, happy to reopen if we do find a bug.

> couchdb 1.6 crash on FreeBSD 10
> -------------------------------
>
>                 Key: COUCHDB-2287
>                 URL: https://issues.apache.org/jira/browse/COUCHDB-2287
>             Project: CouchDB
>          Issue Type: Bug
>      Security Level: public(Regular issues) 
>          Components: Database Core
>    Affects Versions: 1.6.0
>         Environment: FreeBSD 10 Erlang 17
>            Reporter: Edison Chindrawaly
>
> Dear All,
> I am using FreeBSD 10 and I install couchdb 1.6 from port without any problem. However
upon starting couchdb using service couchdb start, it crashed without having a specific reason.

> I looked for answer in google and many says due to permission in all the folders of couchdb
/var/{run log db}/couchdb and /usr/local/lib/couchdb - I set them all to couchdb and set mod
to 770 as many of results in google. However the couchdb won't start either.
> I tried to run as normal user (not couchdb user) and it will give me this error.
> {error_logger,{{2014,7,30},{10,15,44}},std_error,"File operation error: eacces. Target:
/usr/local/lib/couchdb/erlang/lib. Function: list_dir. Process: code_server."}
> =ERROR REPORT==== 30-Jul-2014::17:15:44 ===
> File operation error: eacces. Target: /usr/local/lib/couchdb/erlang/lib. Function: list_dir.
Process: code_server.
> {"init terminating in do_boot",{undef,[{couch,start,[],[]},{init,start_it,1,[]},{init,start_em,1,[]}]}}
> if I ran as root (service couchdb start) - it won't give me that error above, it just
simply crash with 
> heart_beat_kill_pid = 542
> heart_beat_timeout = 11
> heart: Wed Jul 30 10:00:24 2014: Erlang is crashing .. (waiting for crash dump file)
> heart: Wed Jul 30 10:00:25 2014: Executed "/usr/local/bin/couchdb -k" -> 0. Terminating.
> -----
> Any idea?
> Thanks in advance



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message